Welcome

PI Studio HMI Software

Human Machine Interface (HMI) Programming Software, It is a HMI programming tool for PI Series HMI.

This Help document will briefly introduce the functions, programming process for the software.


Quick Start

Follow the 6 steps below to build a new HMI project:

1. Create a new project: Click [New Project] on the left top corner of software interface to create a new project.

2. Configure project properties: Click [Settings]/ [Communication]or[Project Settings] to set HMI properties.

3. Project design: Create the new screen and add the proper objects to screen.

4. Save and Compile: Save and Compile the project before downloading or running simulator, to make sure HMI project has no problem.

5. Simulation: PI Studio provides two types simulation: Off-Line / On-Line

Off-Line: Simulate project operation on PC without any connection.

On-Line: Simulate HMI and PLC operation on PC by connecting PC with PLC. There is 30 minutes time limit.

6. Download: Click [Download] to download HMI project to HMI.


Programs

Start software:

Decompile:

HMI project copied from HMI need to be de-compiled first.

Project Download/Upload:

Download or upload the HMI file (including HMI project, recipe file and firmware file) using this tool, inculding.


????

Menu

Items | Description
Undo | Undo the last editing action; up to 10 operations are stored in the Undo queue.
Redo | Redo the last editing action.
Cut | Remove the selected object in the project and relocate it on the clipboard.
Copy | Copy the selected object in the project and locate it on the clipboard.
Fast Copy | Copies and multiply the selected object and place them in the screen.
Paste | Place contents from clipboard to the project.
Delete | Remove the selected object from the project.
Select All | Select all of the objects in the screen.
Compile | Compile the project.
Cancel | Cancel the compilation of project.
Download | Download HMI project from PC to HMI.
Off-Line | Start off-line simulator.
On-Line | Start on-line simulator, there is 30 minutes for simulation.


Project Properties

Project: include screen, script and system screen status, by double click the designated property to edit.

Screen: all screens in current project are shown in the screen list.

Script: include global script and global function.

System screen: system sub-screen for keypad display.

Screen 1000: numerical input keypad.

Screen 1001: text input keypad.

Screen 1002: mutual screen, this screen will display on all other screens.

Screen 1003: user login screen.

Screen 1005: Chinese input keypad, include number, letter and symbol input functions.

Screen 1006: user login screen, include user name and password input.

Screen 1007: password change screen.

Screen 1008: instalment payment password input screen.

Screen 1009: instalment payment alert screen.

Screen 5001: timeout list.

Screen editing: Choose the designated screen, then edit the parts and properties on this area.

Preview: Preview the selected screen status.

Compiling: The compile progress will display in this area.


Screen

New screen:Start a new screen, the screen number and name should be unique.

Copy screen: copy a screen from current project or other project to current project.

Close screen: close current screen.

Close all.: close all screens on project

Save: save the modifications for current screen.

Save all: save the modifications for all screens

Delete: delete designated screen.

Properties: display and modify current screen number, name, level, background, etc.

Manager:Display and modify all screen numbers, names, levels, backgrounds, etc.

New: create a new project

Open: open the designated project

Close: close current project


?????

Communication

Click [Setting]-[Communication] to edit the communication parameters of HMI or PLC.


??????

Project Settings

Click [Project]-[Project Settings] to edit HMI general properties, including HMI model, Startup screen, Screensaver, Screen control etc.


Common Object

Button/Switch: perform read/write to designated address depend on switch state.

Input/Display: perform read/write to word address.

Meter Display: display word address value in meter graph.

Chart: show the trend of data change.

Display: control or display the picture from gallery or camera.

Draw: draw the graph by desired shape.

Date/Time: Display current date or time.


Object

Bit Switch:

Bit switch is designed to access the bit-address of the PLC/ HMI.

Word Switch:

when the switch is triggered the value of the word address will change depends on the switch type.

Function Switch:

Function key can implement functions like switch between different screens, copy data to UDisk, file transfer, etc.

Keypad Switch:

Key is a manual data input object; this part must work with the Keypad. User can assign letters or numbers for each switch, when the switch is triggered the data will input to the textbox.

Combination Switch:

Individual functions can be added to one object, to implement multiple tasks at the same time.


Bit Switch

Bit Switch [image] (General/Text/Graphic/Securty/Animation)

Bit switch is designed to access the bit-address of the PLC/ HMI. When bit switch is triggered, the changing of [write address] depends on the mode setting. When [Read] option is selected, the [read address] is editable.

*For example, if the value of [Read address] is "ON", the state of a designated bit address shows the picture and text corresponds to "ON", in contrary, the "OFF" features are shown.


Word Switch

Change a value of the word address, when the switch is triggered the value of word address will change according to the switch type.


Keypad Switch

Keypad switch is designed to input data manually; this object must work with the Keypad.

User can assign letters or numbers for each switch, when the switch is triggered the data will input to the textbox.


????

Function switch

Function key can implement functions like switch between different screens, copy data to UDisk, file transfer, ect.


??????

Combination switch

Individual functions can be added to one object, to implement multiple tasks at the same time.

*For example, add "set bit" and "destination screen" to a combination switch, when press the switch, it will trigger a bit switch while switch to another screen.


Input/display object

Numeric Input/Display:

Numerical input/ display in designated data format, the data is scalable.

Character Input/Display:

Data from PLC is inputted / displayed in ASCII format, multiple continues data can input/ display simultaneously.


Numeric Input/Display

Numeric input/ display in designated data format, the data is scalable.


????/??

Characters input/display

Data from PLC is inputted / displayed in ASCII format, multiple continues data can input/ display simultaneously.


Record Display:

Trend Chart:

Trend graph shows the data as a dynamic curve, the X axis represent the time, Y axis represent the data.

History Trend Chart:

The real-time data in HMI cache will display curve graph, which X axis represent as time, Y axis represent as data.

Data Record Display:

Check recorded alarm, the time span set by the user, and the alarm record will list by the time sequence.

Alarm Record Display :

Check recorded alarm, the time span set by the user, and the alarm record will list by the time sequence.

Recipe Display:

This function is designed to display and modify the formula of the recipe.

File List Display:

This function is designed to display the recipe files.

XY Plot:

The real time data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.

History XY Plot:

The data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.


?????

Trend Chart [image] (General/Advanced)

Trend graph shows the data as a dynamic curve, the X axis represent the time, Y axis represent the data.


History Trend Chart

History Trend Chart [image] (General/Advanced)

The real-time data in HMI cache will display curve graph, which X axis represent as time, Y axis represent as data.

advanced mode please refer Advanced mode.

While using history trend graph, there are 4 bottons will list below the graph,shown as following:

Set: time range setting.

<< :page up in the time range.

>> : page down in the time range.

Fresh: renew the data.


Alarm Record Display

Check recorded alarm, the time span set by the user, and the alarm record will list by the time sequence.


??????

Data Record Display [image] (advanced mode)

Check recorded alarm, the time span set by the user, and the alarm record will list by the time sequence.

?1

advanced mode please refer Advanced mode.

While using Data record display, there are 4 bottons will list below the graph,shown as following:

Set: time range setting.

<<: page up in the time range.

>>: page down in the time range.

Fresh: renew the data.


Recipe Display

This function is designed to display and modify the formula of the recipe.


????

File list

This function is designed to display the recipe files.


XY Plot

XY Trend (General/Advanced)

The real time data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.


History XY Display

History XY Plot [image] (General/Advanced)

The data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.


Date /Time

Date:

Display current data, week on HMI.

Time:

Display current time on HMI.


Time

Display current time on HMI.


Date

Display current data, week on HMI

Classification | Properties | Description
Format | Show date | yy/mm/dd:year/month/day mm/dd/yy:month/day/year dd/mm/yy:day/month/year
 | Display style | Chinese1 English1 Chinese2 English2


Meter Display:

Pointer Meter:

Graph shows the data change in a combination of pointer and dial.


??

Pointer Meter

Graph shows the data change in a combination of pointer and dial.


Display:

Picture:

Import picture though gallery.

Rotation Picture:

Display the data change by rotate the corresponding picture

Drop-down List:

D rop-Down list is designed for display the designated state by text, to select the text in the list, the corresponding state will change

/ [image] Camera Control/Display:

Control/Display the camera image, the camera can only communicate with HMI though Ethernet port.


Picture

The picture can be put on the screen by following steps; Optimize the picture frame on the screen; Double click the object and select from gallery; System will auto adjust the color of the picture harmoniously with the HMI background.


Rotation Picture

Rotating Pictrue

Display the data change by rotate the corresponding picture (only support bmp format), user can set rotation centre, direction, angle etc.


Drop-Down List

Drop-Down List (General/Text)

Drop-Down list is designed for display the designated state by text, to select the text in the list, the corresponding state will change, and the write address will change to the designated state value. (There are 32 states in total, as "0-31").


Camera Control/Display

Camera display [image] /Camera controller

Control and display the camera image,the camera can only communicate with HMI though Ethernet port.

Use dynamic control instruction: read a string from designated system address, then combine the instruction to control the camera image.


Draw

Text:

Add text content in screen.

Point:

Draw point in screen.

Line:

Draw line in screen

Polygon:

Draw polygon in screen.

Cycle:

Draw cycle in screen.

Arc:

Draw cycle in screen.

Rectangle:

Draw rectangle in screen.

Broken Line:

Draw Broken line in screen.

Linear Scale:

Draw linear scale in screen.

Arc scale:

Draw arc scale in screen.

Table:

Draw table in screen.


??

Text

Textbox display the designated text content.


Point

Property | Description
Color | Point color
Type | Point size
Position | The position shown on screen


Line

Property | Description
Line color | N/A
Line type | N/A
Start XY | Start position
End XY | End position
Auto adjustment | In the range of designated value, the line will remain vertical. Unit: pixel.


Polygon

Property | Description
Point number | Maximum point support is 51
Type | N/A
Border | N/A
Pattern | N/A
Foreground | N/A
Background | N/A

Left click the mouse to draw the profile of the polygon, right click to finish drawing.

The points of the polygon can be modified by the point Editor at polygon setting window.

Drag the point needs to be modified to the designated position.


Cycle

1. Radius: X and Y radius represents the horizontal and vertical radius respectively.

2. Centre position: Choose the center position to decide the cycle position.


Arc

Left click to drop the top right point of the arc.

Left click again and rotates clockwise to erase the redundant part of the arc, rotates counter clockwise to create the desired arc.

Left click again to finish drawing.

The profile, start point, end point can be modified by simply dragging.


Rectangle


Border line

Left click on the screen to drop the start point.

Drop the following points by left click on designated area.

Right click the mouse to finish the drawing.

The points of the polygon can be modified by the point Editor at polygon setting window.

Drag the point needs to be modified to the designated position.


Linear scale

Display direction: There are 4 display directions list as, top to bottom, bottom to top, left to right, right to left, corresponding to the following pictures respectively.

7.9.10273 | 7.9.10399 | 7.9.10525 | 7.9.10651
Top to bottom | Bottom to top | Left to right | Right to left

1. Main scale: default main scale number is 10.

2. Sub scale: the number of the sub scale is between the adjacent main scales.


Arc scale

Left click to drop the top right point of the arc scale.

Left click again and rotates clockwise to erase the redundant part of the arc, rotates counter clockwise to create the desired arc scale.

Left click again to finish drawing.

1. Start angle: The angle corresponds to the X axis and the first radius drew.

2. End angle: The angle corresponds to the X axis and the last radius drew.

3. Main scale: Default main scale number is 6.

4. Sub scale: The number of the sub scale is between the adjacent main scales.


Table

1. Rows: The number of textboxes list horizontally.

2. Columns: The number of textboxes list vertically.

3. Invisible: The table frame becomes invisible, excluding the header.

4. Header cross: The options for header cross are No, row, column, and table, which shown in the following table, respectively.

Header cross | No | Row | Column | Table
Effects | 7.9.13284 | 7.9.13286 | 7.9.13288 | 7.9.13290

5. Table cross: The options are No, row, column, and table, which shown in the following table, respectively.

Table cross | No | Row | Column | Table
Effects | 7.9.13403 | 7.9.13405 | 7.9.13407 | 7.9.13409

6. Row header color.

7. Column header color.

8. Header width: The header width does not affect the table size.


Bit Library

Two types of pictures in Gallery: User picture and System picture.

Click [setting]-[gallery]: User can see all the pictures in the bitmap, import and export the picture. User can add Multi-states in the project.


Font library

Users select the needed fonts and add to the font library.

Click [Project]-[Library] -[Font Library]


Text Library

Text library contains commonly used text. It avoids setting the text repeatedly. HMI provides up to 8 languages in text library.

Click [Project]-[Library]-[Text Library].

Export/import: HMI support CSV file, export or import csv file.


Address Library

Address library contains commonly used addresses. It not only avoids setting the addresses repeatedly but also expresses the function of an address more clearly.

Click [Project]-[Library]-[Address library]

Export CSV: Export address library to csv file.

Import CSV: Import existing csv file to address library.


????

Address Mapping

Description

Address mapping is the operation to build the relationship between two different addresses. Forwarding address from source address to destination address, so the value in both addresses would be same according to the predefined mapping mode. Both addresses could be from different, in this way, to make HMI processing faster.

*For example: forward "D0" to "HDW100" (length: 10), so the address D0,D1,..D9 would be related to HDW100,HDW101..HDW109.

Settings

Click [Project management]-[Address mapping] .

Function

Read only: Destination address only read the value from source address. it is unable to write value to source address.
Read/Write: The value of source and destination address always keep same.
Mapping control: Set the control bit to start or stop mapping.


Recipe

Click [Project]-[Data Tool]-[Recipe] .

Click [Add] or double click recipe item to edit the properties of recipe.


Alarm

PI software support bit alarm and word alarm, the alarm data and history can be saved in SD card, Udisk or HMI flash storage.

Bit Alarm

Word Alarm


Bit Alarm Setting

Press [bit alarm] [image] in data tool, the setting window shown as following:

Property | Description
Bit address | Read address.
Record Alarm | Record history data.
Upload | Upload the alarm time and information to designed address or not. Click the "Edit" beside "Advanced setting" to select the upload information.
Trigger mode | The conditions trigger alarm.
Content | Alarm message which display on screen.
Beep when alarm | Beep when alarm on.
Notify | Set control bit on when alarm on, clear alert when alarm off.
Alarm screen | Pop-up alarm screen (it must be sub-screen).
Location | The location of the screen alarm display.
Interval time | Reopen the alarm screen when alarm screen closed.
Pop-up once | Pop up alarm screen once.
Close window when Alarm cancelled | Automatically close the alarm screen when alarm off.


Word alarm

Press [word alarm] [image] in data tool setting:

Settings

Properties | Description
Device name | Alarm name.
Record Alarm | Record history alarm information.
Device address | Set alarm address.
Data Format | Set data format.
Alarm description | Set alarm information when alarm is on.
High Limit Alarm | Alarm is on when it reaches high limit.
Low Limit Alarm | Alarm is on when it reaches high limit.
Range Alarm | Alarm is on when it is within the range.
Fixed value alarm | Alarm is on when it equals to a constant.

Alarm conditions

Alarm is set ON when designated address meet the following condition:

1. High Limit Alarm: Alarm is ON when it reaches high limit.

2. Low Limit Alarm: Alarm is ON when it reaches low limit.

3. Range Alarm: Alarm is ON when it reaches the range.

4. Equal alarm: Alarm is ON when the value equals to the preset value.

5. Alarm record: save the alarm data to Udisk or SD card

6. Alarm information: Descript the alarm by preset text. The alarm text support up to 8 different languages, the edit window is shown as following:

1. Alarm screen: when the alarm conditions are met, the sub alarm screen will display on designated location, default setting is none.

2. Pop-up once: the alarm screen will not keep pop-up after close.

3. Close window when alarm cancelled: Automatically close the alarm screen when alarm off.


Data Record (General/Setting)

The data record function is organized by the following structure; multiple record groups can be traced.

Data record on SD card follows the rules above as well.


?????

Trend Chart(Trend Chart/History Trend Chart)

Click [Project]-[Data Tool]-[Trend Chart].


??XY???

 History XY Plot

Click [Project]-[Data Tool]-[History XY Plot].


General:

General

Script Access to Device

Checking Grammar

Grammar Error

Hints to Use Script


????

Script Function:

Mathematical | Data Transformation | Strings | Bit Control |  | Applied Function
Abs | A2H | InStr | ClrB |  | AddrStringCompare
Acos | Asfloating | LEFT | InvB |  | beep
Asc | AsInteger | Len | SetB |  | IsFloating
Asin | AsString | LTrim | Compare |  | IsInteger
Atan | B2W | Mid | IF..THEN GOTO .. | IF = | IsString
Atan2 | BCD | Right |  | IF >< | Log
Cos | BIN | RTrim |  | IF > | Log10
Exp | Chr | Trim |  | IF >= | MSeconds
Hypot | D2F | UCase |  | IF < | NewNoAddr
Tan | D2Float | Variable |  | IF <= | NewStatAddr
Sin | DegToRad | Pi |  | IF AND = 0 | NStringCompare
Sqr | F2D | true |  | IF AND >< 0 | power
SignedInt16 | F2S | false | IF | IF = | rand
SignedInt32 | Float2D |  |  | IF >< | ReadAddr
Data Mover | H2A |  |  | IF > | SleepA
BMOV | MAX |  |  | IF >= | WriteAddr
FILL | MIN |  |  | IF < | Others
Process Control | LCase |  |  | IF <= | Dim..as.
GOTO | RadToDeg |  |  | IF AND = 0 | do
FOR | SWAP |  |  | IF AND >< 0 | function
END | W2B |  | ELSE |  | sub
 | W2D |  | ENDIF |  | while
 | W2F |  |  |  |
 | W2S |  |  |  |


Script Type:

Script Type

Initialization Script

Trigger Control

Close Script

Timing Script

Global Function


Modbus All Faction

Modbus Function Code

Notice: In Modbus protocol, allow to access bit address like 100.1, which using the same function code with 16bits read-write.

Word Address | Function Code(HEX) | Data Length | Read or Write
3 | 04 (Read input address) | 16-bits | Read only
 | 06 (Write single holding address)
 | 10 (Write multiple coils)
4 | 03 (Read multiple holding addresses) | 16-bits | ?
 | 06 (Write single holding address)
 | 10 (Write multiple coils)
W6 | 03 (Read multiple holding addresses) | 16-bits | ?
 | 06 (Write single holding address)
 | 10 (Write multiple coils)
W16 | 03 (Read multiple holding address) | 16-bits | ?
 | 0F (Write multiple addresses)

Bit Address | Function Code(HEX) | Data Length | Read or Write
0 | 01(Read coils) | 16-bits | ?
 | 05(Write single coil)
 | 0F(Write multiple coils)
1 | 02(Read discrete inputs) | 16-bits | Read only
 | 05(Write single coil)
 | 0F(Write multiple coils)
W5 | 01(Read coils) | 16-bits | ?
 | 05(Write single coil)
 | 0F(Write multiple coils)
W15 | 01(Read coils) | 16-bits | ?
 | 0F(Write multiple coils)

Address Mapping (Modbus RTU Master)

Modbus will read the value from HMI local address:

HMI Local Address | Modbus Address
HDX3000.0~HDX3499.15 | Bit address type:0 (Range: 0~7999)
HDW3500~HDW7999 | Word address type: 4 (Range: 0~4499)

Bit Address Mapping:

HDX3000.0 = Modbus Address 00(Address Type: 0; Address No.:0)

HDX3000.15 = Modbus Address 015(Address Type: 0; Address No.:15)

HDX3001.1 = Modbus Address 017(Address Type: 0; Address No.:17)

Word Address Mapping:

HDW3500 = Modbus Address 40(Address Type: 4; Address No.:0)

HDW3615 = Modbus Address 4115(Address Type: 4; Address No.:115)

HDW4500 = Modbus Address 4100000(Address Type: 4; Address No.:1000)


General

If the device does not support MODBUS standard, and the protocol is not list in HMI compile software, then user can define the protocol by following instruction to realize simply communication functions like send and receive commands.

Settings

1.Choose [other protocol]-[user defined protocol].

Figure 1

Press [communication]-[user-defined protocol].

Figure 2

Properties | Description
Instruction edit | The required command.
Mode | Write to address or read from the address.
Format | Encode format: HEX or ASCII.
Other | No receiving: does not respond to the receiving command.
 | Send after receiving: respond to the receiving command.
Manually send | Respond once after trigger the address.
 | Address: set the trigger address.
Add | Save this setting.
Cancel | Cancel current settings.
Add | Add a new command.
Edit | Edit the designated command.
Delete | Delete the designated command.
Clear | Clear all the commands.
Instruction list | Browse all current commands.
Parts list | Browse all the parts added.
Import | Import the command files to the instruction list.
Export | Export current command settings to local storage.
Browse | Browse local command files.
Advanced | Combine two commands.
Exit | Complete editing and exit setting.

Press [Add] to create a new command.

Select the Mode as below.

Choose the data format as below.

Instruction edit, when the data format is HEX, use two numbers to represent one 16bit number. ASCII format using characters to input, shown as below.

Check settings, shown as below.

Properties | Description
Add checking | Add checking command when receiving the data.
Back checking | Start position: select the start position of the data which need to check.
 | Length: The data length need to be checked.
Add control character | Add control character in ASCII format.
Differ with send check | Set return checking.

Properties | Description
Part Setting | Part type: bit or word address.
 | Address: the triggering address.
 | Note: description to the part.
Byte order | The numerical display order.

Properties | Description
Return data | Position: the start position of the return data.
 | Length: the return data length.
Write data | Position: the start position of the write data.
 | Length: the write data length.

Properties | Description
Send length | The instruction data will only send designated data length.
Return length | The responds data length.


OpenCAN settings

General

Opencan is based on CAN2.0 standard; user can customize the protocol settings.

Instruction

Choose [setting] on menu bar- [communication]-[setting], select OpenCAN, shown as following.

Settings

Properties | Description
Add | Add a frame for designated address
Insert | Select the position to insert a frame.
Frame manager | Browse current frame settings.
9 Browse | Show the frame setting files in xml format.

Select [Add] and the following settings will show up, as figure 3.

Properties | Description
Frame type | Select between Standard frame and Extended Frame.
Frame format | Select between Data frame and Remote Frame.
Data (Hex) | Use two numbers to represent one 16bit number, separate with blank.
use address | Select address type between bit and word.
Option | Relate the frame and the designated address.
Interaction | HMI send frame and the devices process and respond.
send after receiving | HMI will process and respond after receiving the command.
No response | HMI or devices will not receive any responds
Confirm response | The HMI or devices will check the data received then respond to it.
Data response | HMI or devices will respond the designated data when receiving the frame.
Response ID | The response ID can differ with the sending ID by this setting.

Control address setting shown as below

Properties | Description
Address | Send when the designated address value is not 0.
Ctrlbit | CtrlBit address range is 0~255, the CAN command will only work when the address value is 1.
Manually send | Send once for each time the address is triggered.


Siemens S7-200 Smart Ethernet

General

The driver is designed for Siemens S7-200 Smart series PLC.

Addresses

Type | HMI address | PLC address | Format | Range | note
Word address | IW | I | IWn | 0 ~ 99999 |
 | QW | Q | QWn | 0 ~ 99999 |
 | AIW | AI | AIWn | 0 ~ 99999 |
 | VB | AQ | VBn | 0 ~ 99998 |
 | VW | V | VWn | 0 ~ 99998 | VW0=VB(0~1) VW2=VB(2~3) Even address
 | VD | V | VDn | 0 ~ 99998 | VD0=VB(0~3) VD4=VB(4~7) The addresses need to be the multiply of 4
 | MB | M | MBn | 0 ~ 99999 |
 | MW | M | MWn | 0 ~ 99999 | MW=MB(0~1) MW2=MB(2~3) Even addresses
 | MD | M | MDn | 0 ~ 99999 | MD0=MB(0~3) MD4=MB(4~7) The addresses need to be the multiply of 4
 | TW | T | TWn | 0 ~ 99999 | Current value on timer
 | CW | C | CWn | 0 ~ 99999 | Current value on counter
 | SW | W | SWn | 0 ~ 99999 |
Bit address | I | I | In.x | 0.0 ~ 99999.7 |
 | Q | Q | Q | 0.0 ~ 99999.7 |
 | VW-BIT | V | VW-BITn.x | 0.0 ~ 99999.7 |
 | V | V | Vn.x | 0.0 ~ 99998.7 |
 | M | M | Mn.x | 0.0 ~ 99999.7 |
 | SM | SM | SMn.x | 0.0 ~ 99999.7 |
 | S | S | Sn.x | 0.0 ~ 99999.7 | Read only
 | T | T | Tn | 0 ~ 99999 | Timer state, Read-only
 | C | C | Cn | 0 ~ 99999 | Counter state, Read-only

Setting

Choose the correspond protocol for PLC, at [Setting]-[Communication]-[setting].

Set the Ethernet data.

PLC IP: device IP

PLC port No.:102(fixed)

Network:TCP_Client_2N (fixed)

Wait time:the internet status(?1500ms)


Siemens S7-1200 Ethernet

Settings

Select [Siemens S7-1200 Ethernet] in [setting]-[communication]- [Setting].

Connection

S7-1200 support maximum 3 device connection.

HMI access with PLC with S7 protocol, TSAP is 02.01.

DB access

Offset is DB2 address

To access the B1 data in DB2, use addresses DBxDBB2xxxx, DBxDBW2xxxx, DBxDBD2xxxx.

Represent block: 2xxxx

For example: DBxDBB20000 = DD2.DBB0

DBxDBB20001 = DD2.DBB1


User Restriction

General

HMI allows accessing by multiple users. User need to set the user and group when designing project. Different group have different permission level for accessing. Each user should be added to certain group, it is possible to add one user to different group.

Operating record: record user enter, exit, and the operation record of 9 objects with "user restriction", find the record file in \\flash\\UserOperationLogs.db (On simulator C:\\WECON\UserMgrFile\UserOperationLogs.db).

Setting

1. New User and Group:

Click [system configuration]-[user enter], shown as the following user manager window.

The upper part is group list, the later part is user list. Display on the window bottom is [new user], [copy], [delete user], when use mouse to activate user list; display on the window bottom is [user group], [delete user group] when activate group list. Pop up user property window when click [user], set the password for each user, then add the user to existing group. Modify user password and group when click [property].

Click [import XML], import designated XML configuration file to edit.

Click [export XML], export edited XML configuration file to designated position.

Or create a "New group", then select existing user in following list.

2. Set User permission

Click icon on the tool bar to modify some object restriction together, includes bit switch, word switch, function key, numeric input/display, character input/display, recipe transfer, drop-down list, drop-down list, combination switch totally 9 objects.

Double Click on objects, select [Security]- [user restriction]:

Log work as a part of record information write in operation record file. The information can write in variable. Record the detail information about the operation of HMI.

User Management

HMI allows managing user accounts on screen. Including adding, deleting and editing the user account. HMI provide built-in screen for "log in "and "change password"(screen No.1006 and 1007).

Function | Address | Object type | Address function
Log in | HUW1061~HUW1076 | Drop down list | User name
 | HUW1002 | Character input object | Password
 | HUX1000.0 | Bit switch(On) | OK (log in)
Change password | HUW1061 | Character display object | User name
 | HUW1002 | Character input object | Old password
 | HUW1006 | Character input object | New password
 | HUW1010 | Character input object | Confirm password
 | HUX1000.1 | Bit switch(On) | OK(change password)
Log out | HUW1000 | Bit switch(On) | Log out
New user | HUW1014 | Character input object | User name
 | HUW1006 | Character input object | password
 | HUW1010 | Character input object | Confirm password
 | HUW1150~HUW1169 | Drop down list | Select group
 | HUW1000 | Bit switch(On) | OK(add new user)
Delete user | HUW1061~HUW1076 | Drop down list | User name
 | HUW1000 | Bit switch(On) | OK (delete user)
Select group | HUW1061~HUW1076 | Drop down list | User name
 | HUW1150~HUW1169 | Drop down list | Group name
 | HUW1000 | Bit switch(On) | OK(join)
delete | HUW1061~HUW1076 | Drop down list | User name
 | HUW1150~HUW1169 | Drop down list | Group name
 | HUW1000 | Bit switch(On) | OK (remove)
Delete Profile | HUW1000 | Bit switch(On) | OK(delete)
Export Profile | HUW1000 | Bit switch(On) | OK(export)
Import profile | HUW1000 | Bit switch(On) | OK(import)
Export log file | HUW1000 | Bit switch(On) | OK(export)
Delete log file | HUW1000 | Bit switch(On) | OK (delete)

The notification in HUW10001 shows the current state of HMI.

Value of HSW10001 | Description
1 | Insufficient permissions.
2 | User name does not exist.
3 | User name already exists.
4 | Invalid password.
5 | Log in successfully.
6 | Password you inputted do not match.
7 | Password changed.
8 | User adding complete.
9 | User deleting complete.
10 | Maximum number of users exceeded.
11 | User already exists in the group.
12 | Completed adding user to group.
13 | User not in the group.
14 | User delete successfully.
15 | Import file successfully.
16 | Failed to Import file.
17 | Export file successfully.
18 | Export file failure.
19 | Log out.
20 | Delete Profile successfully.
21 | Delete log file successfully.
22 | Restore the original configuration file successfully

notice:

1. "export configuration file" include export operation log file.

2.extract the configuration files to \\flash\\,(when simulating save to C:\\), if there was a configuration file, please delete current configuration file by "delete profile" tool, then download the current file to HMI, reboot to apply new configuration file

3. Modify configuration during screen running, export configuration file to U disk, import from U disk after modifying.

Operation record of user log in restriction can display with [object]-[record display], view concrete operation of [record display].

Appendix A: record insert variable description

1. Variable format

{variable address, data format}

{HDW100,UW2.1} ---punctuation must be in English.

letter | description
B | binary
O | octal
U | Unsigned decimal
H | hexadecimal
b | BCD
F | 32 bit floating
S | Signed decimal
C | character
W | word
D | Double words


Remote Access

LAN Access

1. Configure HMI IP

2. Download HMI project to HMI, then open the browser in mobile phone, PC or tablet PC, enter the IP to address bar.

Chrome, Firefox, Safari and Internet Explorer(IE9 or above) recommended, any other browser if it can support HTML5.

Internet Access

Configure the "Port forward" of router, mapping to HMI port 80.

Login to the TP-Link TL-WR740N Router

Click the Forwarding link near the left of the page.

You should now see a new menu. In this new menu, click Virtual Servers.

Click the Add New button near the center of the page.


General

HMI Address

HMI provide four types of HMI address for user.

*HSW, HDW, HPW, RPW are word address, HSX, HDX, HPX are bit address;

System Parameters (HSW/HSX)

The address starting with "HSW" are reserved by HMI system, define those address to save the state or parameter of current system. Like system properties, communication parameters etc.

*HSW is related to HSX, (e.g. one word address HSW0 contains 16 bits from HSX0.0 to HSX0.15);

User Data (HDW/HDX):

The address starting with "HDW" are provided for user, saving data to this type of address.

*HDW is related to HDW, (e.g. one word address HDW0 contains 16 bits from HDX0.0 to HDX0.15);

Special Data (HUW/HUX):

Special address reserved by HMI.

*HUW is related to HUX, (e.g. one word address HPW0 contains 16 bits from HPX0.0 to HPX0.15);

System Data (HAW/HAX):

Addresses in this area are holding address, using for storing system data.

Word Address | Format | Range
HSW | HSWn | HSW0~50000 (Holding address: HSW10000~19999)
HDW | HDWn | HDW0~30000 (Holding address: HDW8000~30000)
HUW | HUWn | HUW0~50000
HAW | HAWn | HAW0~200000

Bit Address | Format | Range
HSX | HSXn.m | HSX0.00~50000.15
HDX | HDXn.m | HDX0.00~30000.15
HUX | HUXn.m | HPX0.00~50000.15
HAX | HAXn.m | HAW0.00~200000.15


System Address List

1. System data addresses

Address | Description | Function
HSW0 | Language switch | Multiple language can be set in the project, HMI support maximum 8 languages.
HSW1 | Beep frequency | Frequency range (0-4999)
HSW2 | Beep volume | Volume range(0-80)
HSW3 | Beep time | Time unit ms
HSW4 | Beep ON/OFF | =0,ON; =1, OFF
HSW12 | Screen switch | = 0, only HSW control the screen switch = 1, only HUW control the screen switch
HSW13 | Designated screen switch | The screen will switch to designated screen number.
HSW14 | Current screen number | Display current screen number
HSW24 | Reboot HMI | =1, Reboot
HSW28 | Local time: year | Range: 0-9999
HSW29 | Local time: month | Range: 01-12
HSW30 | Local time: day | Range: 01-31
HSW31 | Local time: hour | Range: 0-23
HSW32 | Local time: minute | Range: 0-59
HSW33 | Local time: second | Range: 0-59
HSW34 | Local time: week | On simulator:0-Sunday, 1-Monday, 2, Tuesday, 3-Wednesday, 4-Thursday, 5-Friday, 6-Saterday On HMI:0-Sunday, 2-Monday, 3- Tuesday, 4-Wednesday, 5-Thursday, 6-Friday, 1-Saterday
HSW35 | Message language | =0: Chinese =1: English
HSW134 | Script reading | 0: read from HMI cache 1: read from PLC
HSW521 | Delete graph and alarm record | =0: no operation =1: HSX521.0 = 1, delete all records =2: HSX521.1 = 1, delete all trend graph =4: HSX521.2 = 1,delete all alarm records =8: HSX521.3 = 1, delete all word alarm records
HSW522 | Copy graph and data record to Udisk | =0: no operation =1: HSX522.0 = 1, copy all record =2: HSX522.2 = 1, copy history XY trend graph =8: HSX522.3 = 1, copy alarm record =32: HSX522.5 = 1, copy recipe
HSW523 | Copy graph and data record to SD card | =0: no operation =1: HSX523.0 = 1, copy all record =4: HSX523.2 = 1, copy history XY trend graph =8: HSX523.3 = 1, copy alarm record
HSW524 | Copy graph and alarm record to Udisk | =0: no operation =4: HSX524.2 = 1, copy history XY trend graph =8: HSX524.3 = 1, copy alarm record =16: HSX524.4 = 1, copy history alarm record =32: HSX524.5 = 1, copy data record
HSW525 | Copy graph and alarm record to SD card | =0: no operation =4: HSX525.2 = 1, copy history XY trend graph =8: HSX525.3 = 1, copy alarm record =16: HSX525.4 = 1, copy history alarm record =32: HSX525.5 = 1,copy data record
HSW526 | Delete file list | =0: no operation =1: HSX526.0 = 1, delete designated file =2: HSX526.1 = 1, delete all files
HSW10000~HSW19999 | Power OFF protection |
HSW10035 | The Ethernet parameter is only editable, when the settings are programmed in HMI software. | Local IP address high endian 1
HSW10036 |  | Local IP address high endian 2
HSW10037 |  | Local IP address high endian 3
HSW10038 |  | Local IP address high endian 4
HSW10039 |  | Local IP address high endian 4
HSW10040 |  | Local mask IP address high endian 2
HSW10041 |  | Local mask IP address high endian 3
HSW10042 |  | Local mask IP address high endian 4
HSW10043 |  | Local gateway high endian 1
HSW10044 |  | Local gateway high endian 2
HSW10045 |  | Local gateway high endian 3
HSW10046 |  | Local gateway high endian 4
HSW10047 |  | Local port address
HSW10201 | Port mapping ON | =0, OFF (default) =1, ON
HSW10202 | Mapping port number | Port number
HSW10203 | Automatic DNS | =0, OFF (default) =1, ON
HSW10204--HSW10460 | Automatic DNS http require |

2. Communication addresses

Port | Description | Address | Details
COM1 | Communication | HSW010061 | 0 - 232 1 - 485 2 - 422
 | Baud rate | HSW010062 | 0 - 1200 1 - 2400 2 - 4800 3 - 9600 4 - 19200 5 - 38400 6 - 57600 7 - 115200 8 - 230400
 | Data bit | HSW010063 | 7 - 7 bit 8 - 8 bit
 | Stop bit | HSW010064 | 1 - 1bit 2 - 2bit
 | Check bit | HSW010065 | 0- None 1- ODD 2- EVEN
 | Wait timeout | HSW010066 |
 | Read timeout | HSW010067 |
 | Retry time | HSW010068 |
 | Retry timeout | HSW010069 |
 | HMI station number | HSW010070 |
 | PLC station number | HSW010071 |
COM2 | Communication | HSW010072 | 0 - 232 1 - 485 2 - 422
 | Baud rate | HSW010073 | 0 - 1200 1 - 2400 2 - 4800 3 - 9600 4 - 19200 5 - 38400 6 - 57600 7 - 115200 8 - 230400
 | Data bit | HSW010074 | 7 - 7 bit 8 - 8 bit
 | Stop bit | HSW010075 | 1 - 1 bit 2 - 2 bit
 | Check bit | HSW010076 | 0- None 1- ODD 2- EVEN
 | Wait timeout | HSW010077 |
 | Read timeout | HSW010078 |
 | Retry time | HSW010079 |
 | Retry timeout | HSW010080 |
 | HMI station number | HSW010081 |
 | PLC station number | HSW010082 |
COM3 | Communication | HSW010083 | 0 - 232 1 - 485 2 - 422
 | Baud rate | HSW010084 | 0 - 1200 1 - 2400 2 - 4800 3 - 9600 4 - 19200 5 - 38400 6 - 57600 7 - 115200 8 - 230400
 | Data bit | HSW010085 | 7 - 7 bit 8 - 8 bit
 | Stop bit | HSW010086 | 1 - 1 bit 2 - 2 bit
 | Check bit | HSW010087 | 0- None 1- ODD 2- EVEN
 | Wait timeout | HSW010088 |
 | Read timeout | HSW010089 |
 | Retry time | HSW010090 |
 | Retry timeout | HSW010091 |
 | HMI station number | HSW010092 |
 | PLC station number | HSW010093 |
COM1-2 | Communication | HSW010094 | 0 - 232 1 - 485 2 - 422
 | Baud rate | HSW010095 | 0 - 1200 1 - 2400 2 - 4800 3 - 9600 4 - 19200 5 - 38400 6 - 57600 7 - 115200 8 - 230400
 | Data bit | HSW010096 | 7 - 7 bit 8 - 8 bit
 | Stop bit | HSW010097 | 1 - 1 bit 2 - 2 bit
 | Check bit | HSW010098 | 0- None 1- ODD 2- EVEN
 | Wait timeout | HSW010099 |
 | Read timeout | HSW010100 |
 | Retry time | HSW010101 |
 | Retry timeout | HSW010102 |
 | HMI station number | HSW010103 |
 | PLC station number | HSW010104 |
COM2-2 | Communication | HSW010105 | 0 - 232 1 - 485 2 - 422
 | Baud rate | HSW010106 | 0 - 1200 1 - 2400 2 - 4800 3 - 9600 4 - 19200 5 - 38400 6 - 57600 7 - 115200 8 - 230400
 | Data bit | HSW010107 | 7 - 7 bit 8 - 8 bit
 | Stop bit | HSW010108 | 1 - 1 bit 2 - 2 bit
 | Check bit | HSW010109 | 0- None 1- ODD 2- EVEN
 | Wait timeout | HSW010110 |
 | Read timeout | HSW010111 |
 | Retry time | HSW010112 |
 | Retry timeout | HSW010113 |
 | HMI station number | HSW010114 |
 | PLC station number | HSW010115 |

2. Communication control

Communication No. | Station No. | Control bit | Communication lamp | Description
1 | 0~15 | HSX550.0~550.15 | HSX558.0~558.15 | Default setting, ON=0; OFF=1. normal=0; error=1
 | 16~31 | HSX551.0~551.15 | HSX559.0~559.15
 | 32~47 | HSX552.0~552.15 | HSX560.0~560.15
 | 48~63 | HSX553.0~553.15 | HSX561.0~561.15
2 | 0~15 | HSX566.0~566.15 | HSX574.0~574.15
 | 16~31 | HSX567.0~567.15 | HSX575.0~575.15
 | 32~47 | HSX568.0~568.15 | HSX576.0~576.15
 | 48~63 | HSX569.0~569.15 | HSX577.0~577.15
3 | 0~15 | HSX582.0~582.15 | HSX590.0~590.15
 | 16~31 | HSX583.0~583.15 | HSX591.0~591.15
 | 32~47 | HSX584.0~584.15 | HSX592.0~592.15
 | 48~63 | HSX585.0~585.15 | HSX593.0~593.15
4 | 0~15 | HSX598.0~598.15 | HSX606.0~606.15
 | 16~31 | HSX599.0~599.15 | HSX607.0~607.15
 | 32~47 | HSX600.0~600.15 | HSX608.0~608.15
 | 48~63 | HSX601.0~601.15 | HSX609.0~609.15
5 | 0~15 | HSX614.0~614.15 | HSX622.0~622.15
 | 16~31 | HSX615.0~615.15 | HSX623.0~623.15
 | 32~47 | HSX616.0~616.15 | HSX624.0~624.15
 | 48~63 | HSX617.0~617.15 | HSX625.0~625.15
6 | 0~15 | HSX630.0~630.15 | HSX638.0~638.15
 | 16~31 | HSX631.0~631.15 | HSX639.0~639.15
 | 32~47 | HSX632.0~632.15 | HSX640.0~640.15
 | 48~63 | HSX633.0~633.15 | HSX641.0~641.15
7 | 0~15 | HSX646.0~646.15 | HSX654.0~654.15
 | 16~31 | HSX647.0~647.15 | HSX655.0~655.15
 | 32~47 | HSX648.0~648.15 | HSX656.0~656.15
 | 48~63 | HSX649.0~649.15 | HSX657.0~657.15
8 | 0~15 | HSX662.0~662.15 | HSX670.0~670.15
 | 16~31 | HSX663.0~663.15 | HSX671.0~671.15
 | 32~47 | HSX664.0~664.15 | HSX672.0~672.15
 | 48~63 | HSX665.0~665.15 | HSX673.0~673.15
9 | 0~15 | HSX678.0~678.15 | HSX686.0~686.15
 | 16~31 | HSX679.0~679.15 | HSX687.0~687.15
 | 32~47 | HSX680.0~680.15 | HSX688.0~688.15
 | 48~63 | HSX681.0~681.15 | HSX689.0~689.15
10 | 0~15 | HSX694.0~694.15 | HSX702.0~702.15
 | 16~31 | HSX695.0~695.15 | HSX703.0~703.15
 | 32~47 | HSX696.0~696.15 | HSX704.0~704.15
 | 48~63 | HSX697.0~697.15 | HSX705.0~705.15
11 | 0~15 | HSX710.0~710.15 | HSX718.0~718.15
 | 16~31 | HSX711.0~711.15 | HSX719.0~719.15
 | 32~47 | HSX712.0~712.15 | HSX720.0~720.15
 | 48~63 | HSX713.0~713.15 | HSX721.0~721.15
12 | 0~15 | HSX726.0~726.15 | HSX734.0~734.15
 | 16~31 | HSX727.0~727.15 | HSX735.0~735.15
 | 32~47 | HSX728.0~728.15 | HSX736.0~736.15
 | 48~63 | HSX729.0~729.15 | HSX737.0~737.15
13 | 0~15 | HSX742.0~742.15 | HSX750.0~750.15
 | 16~31 | HSX743.0~743.15 | HSX751.0~751.15
 | 32~47 | HSX744.0~744.15 | HSX752.0~752.15
 | 48~63 | HSX745.0~745.15 | HSX753.0~753.15
14 | 0~15 | HSX758.0~758.15 | HSX766.0~766.15
 | 16~31 | HSX759.0~759.15 | HSX767.0~767.15
 | 32~47 | HSX760.0~760.15 | HSX768.0~768.15
 | 48~63 | HSX761.0~761.15 | HSX769.0~769.15
15 | 0~15 | HSX774.0~774.15 | HSX782.0~782.15
 | 16~31 | HSX775.0~775.15 | HSX783.0~783.15
 | 32~47 | HSX776.0~776.15 | HSX784.0~784.15
 | 48~63 | HSX777.0~777.15 | HSX785.0~785.15
16 | 0~15 | HSX790.0~790.15 | HSX798.0~798.15
 | 16~31 | HSX791.0~791.15 | HSX799.0~799.15
 | 32~47 | HSX792.0~792.15 | HSX800.0~800.15
 | 48~63 | HSX793.0~793.15 | HSX801.0~801.15


hidd_setporttable_1.htm

HMT location

Import wmt fill to decompile, then open the project with PI-studio.


hidd_setporttable_1.htm

Location

Saving route of decompiled file.


hidd_setporttable_1.htm

PC Port

Transfer the project file, firmware to HMI, while using the Ethernet to transfer the files, type the IP address, then choose the device to start transfer.


hidd_setporttable_1.htm

File type

There are two types files, project file(.wmt), firmware file(.osf2).


hidd_setporttable_1.htm

Password

Only needed when upload the file, if the "designer password" is available.


hidd_setporttable_1.htm

Advanced

Save the selected data then download the files to HMI.


hidd_setporttable_1.htm

HMI-->PC

Upload project file from HMI to PC.


hidd_setporttable_1.htm

PC-->HM

Download file from PC to HMI.


hidd_setporttable_1.htm

Sync HMI clock

Update the HMI system time with PC time.


hidd_setporttable_1.htm

Recalibrate

Recalibrate HMI touch screen.


hidd_setporttable_1.htm

Delete Setting

Delete all configuration files in HMI.


hidd_setporttable_1.htm

HMI version

Check the HMI firmware version.


hidd_setporttable_1.htm

Driver installer

Install the USB driver for PC.


hidd_setporttable_1.htm

Device Type

Select proper HMI Model for current HMI device.


hidd_setporttable_1.htm

Initial Screen

Display the first screen when HMI startup.


hidd_setporttable_1.htm

Switch Action

Switch Action: the action condition about operating the switch.

Backlight:Auto sleep after designated time of inactivity, this function disabled when alarm is on.


hidd_setporttable_1.htm

Operation Record

Record the operation details after logging in.


hidd_setporttable_1.htm

Byte Order

Set the floating data format (Little-endian by default).


hidd_setporttable_1.htm

Date Record Storage

The storage for saving data record.


hidd_setporttable_1.htm

Overflow Alarm Record Storage

The Storage for additional alarm record, there are 6000 records limit for internal storage, the additional alarm record will be saved into designated storage.


hidd_setporttable_1.htm

Pointer

Display the pointer on HMI screen.


?????

HMI IP

Set the IP for local HMI device.
Click [Project]-[Project Settings]-[HMI IP]
HMI IP can be changed by special system addresses.


hidd_setporttable_1.htm

Enable

Password: The initial password for the installment credit
Expire Date: Date setting for first payment.
Current Time: Display the current PC time
Valid Days: counting the days before first payment


hidd_setporttable_1.htm

Installment Trigger

Set Bit:Set bit when HMI displays the installment screen.
Clear Bit: Clear bit when user enter the right installment password.
Upcoming Alert: HMI show the installment alert before expire date (before 1,3 or 5 days)


hidd_setporttable_1.htm

Password

Enter the password for payment, the password contains the password for next payment,


hidd_setporttable_1.htm

Generate Password

Password Tool generate the password automatically, this password is for payment.


hidd_setporttable_1.htm

Admin Password

Admin password is available for every payment, this password will end all payments.


??????

Installment

The HMI requires the password when it reach expire time. Click [Project]-[Project Settings]-[Instalment].

Example: set the password (123456) in above picture, and the expire date for first payment is 2015-07-15 . HMI display password screen on 2015-07-15 or later. Administrator can use the password tool below to generate the new password for next payment,it means the new password already contains the new password and expire date.


hidd_setporttable_1.htm

HMI IP

Set the IP address for HMI.


hidd_setporttable_1.htm

Port Mapping

Set the port number of HMI, in same local area network, it needs different port number to distinguish different HMI,


hidd_setporttable_1.htm

Static IP Assistant

Build the relationship between HMI IP (LAC) and Internet IP:
Oray Sign on: sign on Oray account ,then input the user name and password here.
Notice: ?For same local area network, it only requires one HMI to sign in to Oray.


Database

Configure the source for database.


hidd_setporttable_1.htm

Data Source

Set the folder for database


hidd_setporttable_1.htm

Device Connection

Show all external devices


hidd_setporttable_1.htm

New

Add a new device


hidd_setporttable_1.htm

Setting

Change the setting of connection


hidd_setporttable_1.htm

PLC Connection

The pinout details about the device wiring


hidd_setporttable_1.htm

Station No.

HMI No.: Set HMI station No. (0 by default).

PLC No.: Set PLC station No. (by default).


hidd_setporttable_1.htm

HMI Model

The HMI model setting for HMI project.


hidd_setporttable_1.htm

COM

Connect: RS232,RS485,RS422

(COM2 cannot support RS422 connection).

Parity bits: EVEN ODD SPACE NONE

Data bits: 7 or 8.


hidd_setporttable_1.htm

Ethernet

The parameter of Ethernet setting

Network Type:

TCP_Client_2N: TCP Protocol, multiply PLC connection.

UDP_Client_2N: UDP Protocol, multiply PLC connection.

TCP_Server:TCP Protocol , HMI work as server.


hidd_setporttable_1.htm

Timeout

Wait timeout (ms): HMI wait PLC response.

Receive timeout (ms):The max. time between HMI receive the character.

Retry count:Retry times when communication timeout.

Sequential Length:(0: default length 10), read or write the sequential length of device address.


hidd_setporttable_1.htm

User-defined protocol

Setting about User-defined protocol.

Setting about CAN protocol.


hidd_setporttable_1.htm

COM Pinout

The pinout details about the selected HMI model.


Project

Compile: The project needs to be compiled before downloading or running simulator, compiling the HMI project to create project file with extension "wmt", which can be recognized by HMI.

Cancel:Cancel compile.

Download:Download HMI project from PC to HMI via network or USB cable.

Off-Line:Offline simulation is the process to simulate the HMI project without any connection, the project operation can be simulated on PC before downloading to HMI.

Online-Line:Online simulation is a process to simulate HMI project with external device connection, it enables the connection between Device and PC without connecting HMI. The project file can be edited before downloading and greatly saves time. (There is a 30-minute online simulation limit.)


hidd_setporttable_1.htm

Write address

Bit switch controls PLC or HMI internal register address.


hidd_setporttable_1.htm

Read

Bit switch is the read address points to the state of bit. Tick when read and write address are the same.


hidd_setporttable_1.htm

Read address

Read and display PLC or HMI internal register address state.


hidd_setporttable_1.htm

Mode

OFF: set off the write address;
ON: set on the write address;
reset: set on the write address when switch pressed, set off when switch released;
reset delay: set off the write address after setting time, when press next bottom;

(*for example: assign the delay time as 5, set off after 5 seconds when press bottom)
switch: write address switch between 0 and 1, each time the switch is triggered.


hidd_setporttable_1.htm

Display inverted

Display the picture or text inverted.

*for example, the value of write address is set ON, the OFF mode is displayed.


hidd_setporttable_1.htm

Blinking state

Blinking while the switch is triggered, the frequency is editable.

Blink when ON: blink when the write address is ON.
Blink when OFF: blink when the write address is OFF.
Blink alternately when ON: blink alternately when the write address is ON.
Blink alternately when OFF: blink alternately when the write address is OFF.
Write address is effective when blink is ON.


hidd_setporttable_1.htm

Hide

Control bit: Display or hide the bit switch by designated address state.
Hide mode: hide when OFF; hide when ON. Cannot operate after object hided.
Invisible: object keeps hiding during project running.


???

Bit switch [image] (General/Text/Graphic/Security/Animation)

The texts can be assigned to an object; the changing of the content depends on the state of the object.

*For example: Add the text "OFF" and "ON" to a bit switch, state 0 correspond to text "OFF", state 1 correspond to text "ON", when the switch is triggered the text content will shown as "ON".


Use text library

From text library

Text library: Select text from text library, display on the object.

State Editor: edit all states for the selected text.


hidd_setporttable_1.htm

Current state

Switch the states to view or edit the text.


hidd_setporttable_1.htm

Apply text to all

Apply the content to all states for the selected language.


hidd_setporttable_1.htm

Apply style to all

Apply the format to all states for the selected language.


hidd_setporttable_1.htm

Language

Input the corresponding state content on the language window, each state has three languages to display.


hidd_setporttable_1.htm

Font

Edit the font for the selected language. Display the number of characters in the textbox.


hidd_setporttable_1.htm

Apply text color

Apply the selected color for all text.


???

Bit switch [image] (General/Text/Graphic/Security/Animation)

The graphics can be assigned to an object; the changing of the graphic depends on the state of the object.


hidd_setporttable_1.htm

Position and size

Position means object locates on the whole screen. Size describes object display, modify object width and height to change size.


???

Bit switch [image] (General/Text/Graphic/Security/Animation)

Object lock , trigger conditions and password can be set in this function.


hidd_setporttable_1.htm

Object lock

Object lock trigger conditions and password can be set in this function. Select [hide lock icon] to make object invisible. Select [inverse signal] to control designated bit is 0.


hidd_setporttable_1.htm

Touch function

Touch available: the object is touchable when selected.

Beep: the object is beeping when selected.The object is beeping when selected.


hidd_setporttable_1.htm

Triggering

Trigger has six types:
no trigger:The object cannot be triggered.
Trigger before press: Set the read address ON after the first data input.
Trigger after press: Set the read address ON after data input.
Trigger and reset after press: Reset the read address after data input.
Trigger and reset before press: Reset the read address after data input.
Trigger before press, reset after: Set the read address ON while input the data, reset after pressing [ENTER]


hidd_setporttable_1.htm

User restriction

Users can set enable password for object, operate some function only has the password.


???

Bit switch [image] (General/Text/Graphic/Security/Animation)

Moving and deforming the object by designated addresses.


hidd_setporttable_1.htm

Gain

The movement scale will enlarge for a designated proportion.


hidd_setporttable_1.htm

Movement

The picture will move alongside the designated direction.

Movement type: X direction, Y direction, X and Y.


hidd_setporttable_1.htm

Deform

Deform object display size on screen, mainly depends on width and height.

Deform type: left, right, up, down, left and right, up and down, right/left and up/down, right/left or up/down.


hidd_setporttable_1.htm

Edit

Read address: read the value from set address.

Write address: Edit the value of Address for the device. The value of [Read Address] is equals to [Write Address] if write address is empty and object allow to input.


hidd_setporttable_1.htm

Data format

BCD: display or write data in the way of BCD;
Unsigned decimal: display or write data in the way of BIN;
Singed decimal: display or write data in the way of unsigned BIN.
Word: word switch operate one word;
Double words: word switch operate two words;

Multi-state display: the state of object display will according to read address value, state picture display based on the setting of pattern.


hidd_setporttable_1.htm

Hide

Control object hiding by controlling the state of bit address.
Hide: hide when OFF, hide when ON. Cannot be operated after hiding.
Invisible: the object under keeping hiding during project running.


hidd_setporttable_1.htm

Mode

Set value: Set a constant value for the word address.

Increase: Increase the [operand] value for each time the switch triggered.
Decrease: Decrease the [operand] value for each time the switch triggered.
High/Low limit: The value will not increase/decrease when the value is reached.


Indirect addressing

read address: indirect read address decide to the final read address. Read address up to three.
??????????????:F11. ???????????,???D0,E1,HDW2?????HDW2????,?????22,???????????E1???E23,??????E23????,?????33,???????????D0???D33.??D33?????44,?????????F11???F55,????????F55?
??????????,???,??????????????????????????????,???????????????????????????,????????????
??????????,??????????????????????????,????????????
write address:????????????????????????????


hidd_setporttable_1.htm

Keypad switch

switch: keypad input control character;
ENTER: click enter, close keyboard screen;
DELETE: delete characters before cursor, corresponds to [DEL] on keyboard;
CLEAR: clear the content of HSW45, it is input buffer;
ESC: cancel currently input, close keyboard screen;
others function key apply to T9 input method.
Use in input method: input with ASCII character.


hidd_setporttable_1.htm

Function

previous screen: Switch to previous screen.

Next screen: Switch to next screen.

Pop-up window: Pop-up designated sub-screen, relevant pop-up window setting can be found underneath.
Close window: Close current sub screen.
Return: Return to last screen.
Installment: Pop-up the instalment window instantly, set parameter.
Copy data from CF/SD to UDisk: Transfer data from CF/SD to Udisk for data backup and alarm recording.
Copy data from Flash to UDisk: Transfer data from FLASH memory to Udisk for data backup and alarm recording.


hidd_setporttable_1.htm

Others

Switch to the selected screen, must be based screen.


hidd_setporttable_1.htm

Pop-up window

Pop-up designated sub-screen, setting following as:
1 set pop-up sub-screen number;
2 set coordinate on the left top of sub-screen.


hidd_setporttable_1.htm

Data type

Select copy data from CF/SD to UDisk and copy data from FLASH to UDisk.

Data types divided into: data record file, alarm record file and recipe file.


Combination switch (General)

Combination swtich includes bit operation, word operation calculation, screen jump, click correspond button to add sub-function on the object general window, support up to 100 sub-functions.

(attention: only have one screen jump function during adding sub-function, and locate on the last list).


??????

Combination switch [image] (General)

Combination swtich includes bit operation, word operation calculation, screen jump, click correspond button to add sub-function on the object general window, support up to 100 sub-functions.

(attention: only have one screen jump function during adding sub-function, and locate on the last list).


Combination switch [image] (G eneral)

Combination switch includes bit operation, word operation calculation, screen jump, click correspond button to add sub-function on the object general window, support up to 100 sub-functions.

(Attention: only have one screen jump function during adding sub-function, and locate on the last list).


??????

Combination switch ( General)

Combination swtich includes bit operation, word operation calculation, screen jump, click correspond button to add sub-function on the object general window, support up to 100 sub-functions.

(attention: only have one screen jump function during adding sub-function, and locate on the last list).


hidd_setporttable_1.htm

Browse list

Display all configuration content on the browse list, execute [screen jump] finally.


hidd_setporttable_1.htm

Browse table operation

Delete: select a item function, click [delete]. And also delete several project together.

Delete all: delete the whole function on the combination switch.
Up: move selected item toward the top of browse table.
Down: move selected item toward the end of browse table, [screen jump] must locate in the end, if exist [02] function.


hidd_setporttable_1.htm

Advanced configuration

Control the whole combination switch configuration.

Trigger execution function: control the sub-function option of combination switch configuration by trigger address is ON.

Loop execution: execute each sub-function according to loop time and loop numbers set on advanced configuration.
Loop cycle: the interval between sub-functions execute once with next time.
Loop times: configuration function execute times. 0 stands for infinite loop.

End loop: stop executing sub-function when trigger address is ON.


hidd_setporttable_1.htm

General

Read address: The data from designated address will be displayed.
Write address: it is effective when allow to input. Input data to designated address. Operation address is the same as read/write address when input address is empty and object allow to input.
Keypad: it is standard numeric keypad, allow to input decimal and floating.


hidd_setporttable_1.htm

Display

Input as "*": the data input shown as "*".

Text alignment:
center: data display on the center of object.
Align left: data display on object left alignment.
Align right: data display on object right alignment.

Font: text adopt font content.


hidd_setporttable_1.htm

Data format

Display format
16 bit binary: read/write in binary format.
16 bit octal: read/write in octal format.
16 bit hexadecimal: read/write in hexadecimal format.
16 bit BCD: read/write in BCD format.
32 bit floating: read/write in 32 bit floating format, operation word is double.
16 bit signed decimal: read/write in signed decimal format.
The decimal point position: the decimal point position is effective only when data format is floating and decimal.
Data range: beyond the data range will be not inputted.


hidd_setporttable_1.htm

Label

Used in assigning a name to designated information, the text shown on the left/ right side of the input box.


hidd_setporttable_1.htm

Indirect addressing

Read address: read address decide on the object final read address. Read address has no more than 3.

??????????
??????????????:F11. ???????????,???D0,E1,HDW2?????HDW2????,?????22,???????????E1???E23,??????E23????,?????33,???????????D0???D33.??D33?????44,?????????F11???F55,????????F55?
??????????,???,??????????????????????????????,???????????????????????????,????????????
??????????,??????????????????????????,????????????
????????????????????????????


????/??

Numeric input/display

Numerical input/ display in designated data format, the data is scalable.


hidd_setporttable_1.htm

Display

Default: set in default.

Upper bit "zero": Upper bit "zero".
Hide "zero": the display window is blank when the value is zero.


hidd_setporttable_1.htm

Proportional

It is scaled to be valid.
Display value = PLC * gain + offset, only when data is decimal or floating to be valid.

Scale assistant: input original value and result, then calculate the scale proportion.


hidd_setporttable_1.htm

Other function

Rounding numbers: rounding need to remain effective numbers of bit.

Dynamic limits: inputting data range controlled by dynamic, set high and lower limits address, address value decide on data range, high limit cannot be lower than low limit.


hidd_setporttable_1.htm

General

Read address: object read the first of text data.
Write address: inputted string will be written in address when allow to input. Write and read address are the same when write address is empty and object allowed to input.

Keypad: it is effective when allowed to input; keypad has some condition: 1, screen existence; 2, sub-screen; 3, include keypad object
Insert digital keypad: use insert character keypad on HMI, input all of ASCII from 1-10, a-z, A-Z.

Read 2 words: read address is 2 words format.


hidd_setporttable_1.htm

Display

Input as "*": the data input shown as "*".

Text alignment:
Center: data display on the center of object.
Align left: data display on object left alignment.
Align right: data display on object right alignment.

Operation character: character input/display constant word numbers, support most 32 words.


hidd_setporttable_1.htm

Enable

Select channel number needs to be displayed.


hidd_setporttable_1.htm

Curve No.

The line type and color is editable for each curve number selected.


Curve numbers

Group setting

It can set some more record groups on trend display configuration, each record group has many curve numbers. On data configuration must have record group, otherwise curve buffer data not exist.

According to the value of setting address correspond curve number, if select "curve number is variable".


?????

Trend Chart [image] (General/Advanced/Advanced mode)

Trend graph shows the data as a dynamic curve, the X axis represent the time, Y axis represent the data.


hidd_setporttable_1.htm

Range

The data range for the graph can be set as a variable.


hidd_setporttable_1.htm

Duration

Set the range of trend graph display, use second as unit.


hidd_setporttable_1.htm

Enable

Select channel number needs to be displayed, then set different curve style and color according to requirement. Appear "*" before correspond curve number once the curve number enabled,


hidd_setporttable_1.htm

Group setting

It can set some more records groups on trend display configuration, each record group has many curve numbers. On data configuration must have record group, otherwise curve buffer data not exist.

According to the value of setting address correspond curve number, if select "curve number is variable".


?????

History Trend Chart [image] (General/Advanced)

The real-time data in HMI cache will display curve graph, which X axis represent as time, Y axis represent as data.


hidd_setporttable_1.htm

Y Limit

Set curve graph max and min. Select variable from [data range], then enter the value address if the data read from other address.


hidd_setporttable_1.htm

Start address

Start address: Custom object for query function, HMI system assign address according to the settings, and four control key and query screen will be created, user can see the query details in this query screen.


hidd_setporttable_1.htm

Start time

Set start time and condition of data view.


hidd_setporttable_1.htm

Appearance

Set appearance of alarm record display object, includes start color, end color, background color, alarm color, confirmation color, release color for selected row.


hidd_setporttable_1.htm

Function setting

Alarm type: alarm mode has current alarm record and history alarm record, select correspond mode according to user needs.

Page control: display current alarm information page according to page control address.

Display in inverse order: the newest alarm message will display on the top of alarm message column.

Alarm record display setting: select information content to display on the alarm record chart, add to [already option] on the side of right.


hidd_setporttable_1.htm

Appearance

Set the appearance of data record display object, include background color, text color and so on.


Function setting

Start address: Custom object for query function, HMI system assign address according to the settings, and four control key and query screen will be created, user can see the query details in this query screen.
Record group numbers: each data record contains plurality of data. Each data record display object only display data of one record group, so set designated group number before displaying.

Display in inverse order: order in default time, the newest alarm message will display on the top of alarm information column.


hidd_setporttable_1.htm

Start time

Start time: set current query time.

Query length: set the time span from start time to end time of query.


hidd_setporttable_1.htm

Color

Set the appearance of recipe displayed object, includes selected color, background color, text color and so on.


hidd_setporttable_1.htm

Function

File type: select file display on the object, file type: recipe file, operation file, address overtime information, online user manager.

Selected row: select a row from display list, write row number into designated address.

File name address: select under filled path correspond address content by editing different address content.

File path: display the path of displayed file path by adding displayed object. Prerequisite to the file type fold must exist.

Refresh address: refresh record display content in real-time when refresh address state is 1.


hidd_setporttable_1.htm

Address control

Start group number address: control displaying from some several rows, which display from correspond groups.
Group number address: control the data of displaying total group.
Start address: display from designated row.
Address number: display designate amount of data.


hidd_setporttable_1.htm

Color

Set the appearance file list object, include selected color, background color, text color and so on.


hidd_setporttable_1.htm

File name

Display all of recipe file of file path.
Selected row: write selected row number from file list to address.
File name: select any file from object list, write correspond file name to address, view recipe file data by setting recipe display object.

File path: add file path from file list.

File type: recipe file and operation record.


hidd_setporttable_1.htm

Curve No.

Select curve number from total, open and set by the side of enable option.


hidd_setporttable_1.htm

Enable

According needs to set different style and color after select correspond curve number.
Read address: *for example, PLC word address is D, it point number is m.(point numbers no more than 800)


XY???1

XY Plot (General/Advanced)

The real time data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.


hidd_setporttable_1.htm

sampling

Auto sampling: according to sample data of cycle after setting cycle. Redraw when sample data changing.
Sampling control: real time sample data and draw when trigger address is 1.

Auto sampling and sampling control are mutual exclusive function, only choose one of the two modes.


hidd_setporttable_1.htm

Range

Set the max and min value of displaying curve. Select [variable data range] then write in address value, if setting data write from other address.


hidd_setporttable_1.htm

Enable

Set according to different curve style and color after select correspond curve number and enable.


hidd_setporttable_1.htm

Curve No.

Select curve number from total, open and set by the side of enable option. Curve number is the same as history XY plot, no more than 32.


hidd_setporttable_1.htm

Group setting

Set some more record group on history XY graph configuration, each group has some more curve number. Data configuration has record group, otherwise curve buffer data is not exist.


??XY?(??)

Histroy XY Plot (General/Advanced)

The data in cache will display as continuous curve or separated points, each point in XY plot needs 2 addresses to set a point.


????????

Advanced mode

Set start address, the next 20 addresses will all be occupied, last 10 address are not functioning right now. If the start address set as HDW0 the next 10 address perform the following functions.

Address | Type | Object | Function
HDW0 | word address | Numerical input | Start time: year
HDW1 | word address |  | Start time: month
HDW2 | word address |  | Start time: day
HDW3 | word address |  | Start time: hour
HDW4 | word address |  | Start time: minute
HDW5 | word address |  | Start time: second
HDW6 | word address |  | Time interval
HDW7 | word address |  | Time interval unit 0=minute, 1=hour, 2=day
HDW8 | word address | Word switch | Default value:1 Page up: value-1, minimum value is 0 Page up: value+1, minimum value is 65535
HDX9.0 | bit address | Bit switch | Auto refresh


hidd_setporttable_1.htm

Edit

Read-Address: Read the value from the set PLC address.


hidd_setporttable_1.htm

Hide

Hide the object when the control bit is triggered.
Invisible: keep hiding the object.


hidd_setporttable_1.htm

Position

Rotating picture position
Appearance: select picture from Gallery.

Counter-clockwise: default rotation direction is clockwise


hidd_setporttable_1.htm

Data Format

16bit-BCD

16bit-signed

16bit-unsigned

32bit-BCD

32bit-signed

32bit-unsigned

32bit-floating


hidd_setporttable_1.htm

Auto rotate

Auto rotate around the picture center.


hidd_setporttable_1.htm

Rotating angle

The rotating angle is determined by designated address.


hidd_setporttable_1.htm

Auto rotate
Cycle time: the picture will rotate every cycle time, unit: 100ms.
Rotation angle: for every rotation time interval, the picture rotate designated angle.
Return: the picture will reset to original position after the maximum angle reached.


hidd_setporttable_1.htm

Edit

Read address: the data will be acquired from designated address.
Write address: the data input will write to designated address.


hidd_setporttable_1.htm

Trigger mode

No trigger

Trigger before write

Trigger after write

Trigger and reset before write

Trigger and reset after write

Trigger before write and reset after


hidd_setporttable_1.htm

?????

?????:????????????????????????????????????????????????
??????????????:F11. ???????????,???D0,E1,HDW2?????HDW2????,?????22,???????????E1???E23,??????E23????,?????33,???????????D0???D33.??D33?????44,?????????F11???F55,????????F55?
??????????,???,??????????????????????????????,???????????????????????????,????????????
??????????,??????????????????????????,????????????
????????????????????????????


?????(??)

Drop-Down list (General/Text)

Drop-Down list is designed for display the designated state by text, to select the text in the list, the corresponding state will change, and the write address will change to the designated state value. (There are 32 states in total, as "0-31").


hidd_setporttable_1.htm

Text library

Display preset text from text library.
All states: edit text for all states.

Current State

View or change the content for the designated state.

Apply text to all

Apply current text content to all other states.

Language

The state content can be edited in the textbox, there are 3 language available for each state.


hidd_setporttable_1.htm

Enable states text control

The text content will change dynamically depends on the designated address.
Current state: the state content need to be changed

Text address: modify the text content by the address value.?
Trigger to set: the address is set to save the content changes.


hidd_setporttable_1.htm

Camera controller

Camera control instruction: press the object to control the movement of the camera by instruction.
Control bit: trigger the switch to control the instruction.
Enable Beep: the object will beep when operate.


hidd_setporttable_1.htm

From text lib

Select text content from text library, show on the objects.

All states: edit text content for all states.


hidd_setporttable_1.htm

View states

Static text only have one state.


hidd_setporttable_1.htm

Apply text to all

Apply current text contents to all other states.


hidd_setporttable_1.htm

Apply style to all

Apply current text style to all other states.


hidd_setporttable_1.htm

Language

Edit the language contents for designated state.


hidd_setporttable_1.htm

Font

Edit the text font for selected language content.


hidd_setporttable_1.htm

Apply

Apply selected text color to all states.


hidd_setporttable_1.htm

Address mapping: set address

Source address: the source address that need to mapping to other address, set one is ok. If use calculation need to set two source address, the result will be saved in destination address.

Only the word address need to set data format, if 32 bit register ,need to choose "32 bit register"


hidd_setporttable_1.htm

Calculation:

Calculation: desginated mathematical relationship between two source address, the result will be saved in destination address.

Mode: Read-write or read only. The value of source address would not change if destination value changed after read only selected .

Length: Mapping address length.


hidd_setporttable_1.htm

Control Bit

Control trigger address.: Open the mapping when set the global control one, not open the mapping when set the global control zero.

Target address: Store the address after mapping, that is the corresponding address.


hidd_setporttable_1.htm

Set mapping global control trigger address

Set mapping global control trigger address is for all word address mapping instruction. The priority of the function is higher than "Control trigger address". Open the mapping when set the global control one, not open the mapping when set the global control zero.


hidd_setporttable_1.htm

The preview of address mapping of all the corresponding of word address (bit address)


hidd_setporttable_1.htm

Recipe name

Assign name to current recipe


hidd_setporttable_1.htm

Quick setting

Set total group, digits, data format.

Notice: the settings are for single group of recipe.


hidd_setporttable_1.htm

Quick setting

Recipe->address: download recipe to designated address
address->recipe: upload recipe from designated address

The addresses will be arranged automatically when the quick setting are completed.


hidd_setporttable_1.htm

Recipe->Address

The recipe data will download to designated addresses, when the trigger address is set ON


hidd_setporttable_1.htm

Address->Recipe

The recipe data will upload from designated addresses, when the trigger address is set ON.


hidd_setporttable_1.htm

Recipe list

The recipe list display all recipe information based on previous setting, elements details in the list are editable.


hidd_setporttable_1.htm

Recipe list

List all recipe details


????

Data record(General/Setting)

Press word alarm [image] on the tool bar

After the setting,press [Add]


hidd_setporttable_1.htm

Data record list

All data record groups are list in this table, the details are editable by double click the designated record group.


hidd_setporttable_1.htm

??

????????


hidd_setporttable_1.htm

??

?????????


hidd_setporttable_1.htm

??

????????????????


hidd_setporttable_1.htm

Import

Import a data record file to the project.


hidd_setporttable_1.htm

Export

Export current data record file to other project.


hidd_setporttable_1.htm

Group name

This name should be unique.


hidd_setporttable_1.htm

Sample cycle

The record time interval, unit: second.


hidd_setporttable_1.htm

??

????????????


hidd_setporttable_1.htm

Control bit

No trigger, trigger record (by sample time), record only once and reset trigger bit, record only once and keep the trigger status.
Control bit: trigger the designated address to active the record.


hidd_setporttable_1.htm

Total channels

The total channel quantity, press update to renew the data on the channel list.


hidd_setporttable_1.htm

Channel list

The channel details will display in this list, the detail information is editable.


hidd_setporttable_1.htm

Quick setting

Set a start channel, the rest of the channels will automatically apply the same settings, the rest addresses will be assigned automatically by system.


hidd_setporttable_1.htm

General (?????)

??????????????????????(????32?)?????(?????????????)????


hidd_setporttable_1.htm

Sample type

There are two sample types, cycle sample and trigger cycle sample.
Sample unit is 100ms


hidd_setporttable_1.htm

Quick setting

Data format: 16-bit signed, 16-bit BCD, 16-bit unsigned, 32-bit BCD, 32-bit signed, 32-bit unsigned, 32-bit floating.
Quick setting: set a start address the following curve will apply the same setting, the addresses will assigned to each curve automatically.


hidd_setporttable_1.htm

Curve list

Display all the curve information, the details are editable.


hidd_setporttable_1.htm

Quick setting

Data format: 16-bit signed, 16-bit BCD, 16-bit unsigned, 32-bit BCD, 32-bit signed, 32-bit unsigned, 32-bit floating.
Quick setting: set a start address the following curve will apply the same setting, the X; Y addresses will assigned to each curve automatically. If X; Y address is not continually, change the address in curve list.


hidd_setporttable_1.htm

Curve list

The curve details will display on this list, the details is editable by double click the designated data.


General

Script is applied to realize complex control functions. HMI compile software provide powerful function, simple operation, reliable script system, the features of script are list as follow:

1. Similar to BASIC grammatical structure;

BASIC work as the first computer language for the general public, it is easy and efficient to use.

2. Support all of program logic control structures;

Software script support three logic control structures: order?condition?loops. It can realize complexity procedures.

3. Powerful function;

Functions of script are divided into two types: system and custom function. System function: the functions that system has identified for customers. Custom function: users can define a function and apply to all scripts.

4. Support variety of data format;

Script support integer, floating, BCD code, byte, byte string and etc.


Script Access to Device

Software script supports an efficiency way to access the device address by using symbol @.

Writing | Meaning | Examples
@B_;@b_; | Access designated bit address | @B_I0.0:access bit address I0.0 @b_HDX0.0:access bit address HDX0.0
@W_;@w_; | Access designated word address | @W_IW0:access word address IW0 @b_HDW0:access word address HDW0
@B_(the number of protocol connection)#(station number):address | HMI connect more than automatic control devices, "#"stands for choosing number before the symbol,":" stands for accessing the station number before symbol. Access the first protocol without "#",access default station number1 without":". | @B_2#2:I0.0:access the bit address I0.0, with the connection number 2 and station number 2; @B_I0.0:access to bit address I0.0;
@W_(the number of protocol connection)#station number):address |  | @W_2#2:IW0:access the bit address IW0, with the connection number 2 and station number 2;

The script can access with the device though: write and read.

For example

If @B_HDX0.0 = 1 then 'read the value from address HDX0.0.

@B_HDX0.0 = 0 'write 0 to address HDX0.0

Else

@B_HDX0.0 = 1 'write 1 to address HDX0.0

Endif

@W_QW0 = @W_QW0 + 1 'read data from address QW0, add 1 to this value then write to address QW0.


Checking Grammar

Check script grammar is correct or not, error occurs when compile error.

Select [image] from script tool bar, system does not prompt grammar error if grammar is correct, system will list all errors for modification.


Grammar Error

In this section common grammar errors of software script are listed as following:

1. Identifier *** contains invalid characters.

2. Attempt to redeclare sub *** .

3. Attempt to redeclare function *** .

4. Attempt to use reserved word *** as identifier.

5. Attempt to use type *** as identifier.

6. Unexpected ')' while parsing arguments for function *** .

7. Cannot parse expression (one of the arguments of function ***) .

8. Cannot parse arguments of *** .

9. Too many arguments for function *** .

10. Not enough arguments for function *** .

11. '(' expected after sub name *** .

12. Unexpected '(' while parsing arguments for sub *** .

13. Cannot parse expression (one of the arguments of sub ***) .

14. Cannot parse arguments of *** .

15. Too many arguments for sub/function *** .

16. Not enough arguments for sub/function *** .

17. Cannot parse expression .

18. '(' expected after function name *** .

19. Unexpected use of sub *** as a part of expression .

20. Illegal statements preceding subs/functions declaration .

21. Unexpected end of file while looking for 'endsub' .

22. End of line expected after 'else'.

23. End of line expected after 'endif'.

24. End of line expected after 'next'.

25. End of line expected after 'wend'.

26. 'while', 'until' or end of line expected afte r'do'.

27. Cannot parse expression after 'while'.

28. Cannot parse expression after 'until'.

29. 'do' without 'loop'.

30. Sub *** contains invalid character'@' .

31. Sub *** already declared.

32. Function *** already declared.

33. Sub name expected after 'sub'.

34. Function name expected afte r'function'.

35. Variable name expected.

36. Argument *** contains invalid character '@'.

37. 'integer', 'floating' or 'string' expected.

38. ''',' or ')' expected.

39. 'endsub' without 'sub'.

40. 'end function' without 'function'.

41. End of line expected after 'beep'.

42. 'dim' unexpected here.

43. Variable name expected after 'dim'.

44. 'as' expected after variable name.

45. 'integer' 'floating' or 'string' expected after 'as'.

46. ',' or end of line expected after type in dim statement.

47. Cannot parse expression after 'while'.

48. End of line expected after' while' condition.

49. 'while' without 'wend'.

50. End of line expected after 'wend'.

51. 'wend' without 'while'.

52. Variable name expected after' for'.

53. '=' expected after variable name.

54. Cannot parse expression after 'for'.

55. 'to' expected.

56. Cannot parse expression after 'to'.

57. Cannot parse expression after 'step'.

58. End of line expected.

59. 'for' without 'next'.

60. End of line expected after 'next'.

61. 'Next' without 'for'.

62. Cannot parse expression after'if'.

63. 'then' expected.

64. Unexpected end of file while looking for 'endif'.

65. Unexpected end of file while looking for 'else' or 'endif'.

66. 'else' without 'if'.

67. 'end if' without 'if'.

68. Label name expected after 'goto'.

69. Unexpected end of line while looking for ')' in function call.

70. ',' expected.

71. Missing ')'.

72. Unexpected end of line in expression.

73. Unexpected end of file in expression.


Hints to Use Script

Script can make project more convenient and flexible to use. Script is useful in realizing complex HMI function. If the script is used improperly, it may affect the efficiency of entire project. So pay attention to the follow issues:

1. Try not to use too much script loops, if the script loops that executes too many times, it might influence the efficiency of HMI.

2. In the cycle scripts, try not to use external register, due to the relatively slow serial communication, frequent access to external registers may cause the execution of scripts severely reduced, even influence the screen respond efficiently. There is fine to use internal register.

3. The maximum script length is 512 rows.


A2H??

Function

Val = A2H(A1)

Description

Convert string A1 to hexadecimal number.

Parameters

A1: convert first four value of the string.

Notice: string must be address(such as:@W_HDW000002).

Val: The value is hexadecimal number.

Example

@W_HDW20=A2H(@W_HDW10) ' convert the string of HDW10 to hex then save in HDW20.

Input: @W_HDW10=255

Result: @W_HDW20=255


Abs??

Function

val = Abs(A1)

Description

The absolute value of A1.

Parameters

A1:the data of absolute value, must be variable.

Val:it is absolute value that is address or variable.

Example

Dim a as integer 'a is defined as integer

a = SignedInt16("@W_HDW0")'convert the data of @W_HDW0 into signed data.

@W_HDW1 = Abs(a) 'assign the returned absolute value to @W_HDW1

Input:@W_HDW0=-6,

Result:@W_HDW1=6

Notice: SignedInt16 function is designed to convert unsigned to signed.


Acos??

Funcition

val = ACos(A1)

Description

To compute the inverse cosine value of A1.

Parameters

A1: float value, can be a address or variable.

Val: return value is float, can be a address or variable.

Example

Dim a ,b as floating 'define two float variable a,b

a = 0.5 'assign the designated value to a

b = ACos(a) 'the inverse cosine value of "a" is a radian which assign to variable b.

'to add the following sentence if needed to view the return value:

float2d("@W_HDW200", b) 'float b written into HDW200.

Result: @W_HDW200=1.047

Notice: please call RadToDeg function to convert radian into angle.


AddrStringCompare??

Function

val = AddrStringCompare(A1, A2, length)

Description

It is designed to compare the designated length of two character strings.the string value is 1 when the two strings are the same.

Parameters

A1, A2:character string, must be an address(such as:"@W_HDW000002")

Length:The length of character string.

Val:Return value, 0 or 1.

Example

if AddrStringCompare("@W_HDW10","@W_HDW0",2)=1 then 'compare the character string of HDW10 and @W_HDW0 whether value are 1.

@W_HDW20=1 '@W_HDW20 display 1

else

@W_HDW20=0 '@W_HDW20 display 0

Endif

Input: @W_HDW10="1a2 ",@W_HDW0="1a2 ",

result:@W_HDW20=1

Input: @W_HDW10="ab2 ",@W_HDW0="12a ",

result:@W_HDW20=0


Asc??

Function

val = Asc(A1)

Description

Return the first character of the string in ASCII value.

Parameters

A1:character string, it can be an address(such as:@W_HDW000002)

val:return value,ASCII value,it can be an address or variable.

Example

@W_HDW10 = Asc("A") 'return the ASCII value of A to HDW10

@W_HDW11 = Asc("a") 'return the ASCII value of a to HDW11

@W_HDW12 = Asc("Apple")'return the first character A of string Apple to HDW12

@W_HDW13 = Asc("123") 'return the first character ASCII value 1 of string 123 to HDW13.

Result: @W_HDW10 = 65

@W_HDW11 = 97

@W_HDW12 = 65

@W_HDW13 = 49


AsFloating

Function

val = AsFloating(A1)

Description

Convert parameter A1 to a float.

Parameters

A1:integer variable.

val:return float value, can be a variable or address.

Example

Dim a as integer 'define a integer variable {a}.

a = @W_HDW10 'assign @W_HDW10 to a

b = AsFloating(a) 'convert integer a to float then assign to b.

b = b/1.2 'add as following sentence when need to view the return value:

Float 2D("@W_HDW11",b)'float variable b written into HDW11.

Input:@W_HDW10=24,

result:@W_HDW11=20.00(set two decimals)


Asin??

Function

val = ASin(A1)

Description

Calculate the arcsine value of A1.

Parameters

A1:Float can be a address or variable.

Val:Return float value, can be a address or variable.

Example

Dim a, b as floating 'define two float variable a,b

a = 0.5 'assign the designated value to a

b=ASin(a) 'calculate the arcsine value of a ,assign the radian to b.

'Add the following command if need to view the return value:

float2d ("@W_HDW200", b) 'float variable b written into HDW200

Result:@W_HDW200=0.524

Notice: please call RadToDeg function to convert radian into angle.


AsInteger??

Function

val = AsInteger(A1)

Description

Convert parameter A1 to integer value.

Parameters

A1:floating must be a variable.

Val:return integer value can be a variable or address.

Example

Dim a as floating 'define floating variable a

a = D2Float("@W_HDW0",a) 'use D2Float function to save the float date of HDW0 in a

b= AsInteger(a) 'convert the float a into integer,the return value assigned to b

@W_HDW10=b 'save b to HDW10

Input: @W_HDW0=20.12,

Result: @W_HDW10=20


AsString

Function

val = AsString(A1)

Description

Convert parameter A1 to a character string.

Parameters

A1:not string parameter,it can be a variable.

Val:return string value, variable or address.

Example

Script 1:

a=123 'assign a value to a

b=234 'assign a value to b

c=AsString(a)+AsString(b) 'convert a and b to string then add up the two strings ,assign the result to c.

@W_HDW0=c 'assign c to HDW0

d=a+b 'plus a with b

@W_HDW100=d 'assign d to (HDW100)

result:@W_HDW0=123234

@W_HDW100=357

Script 2:

W2S("@W_HDW200","@W_HDW300","02d")

W2S("@W_HDW210","@W_HDW400","02d")

W2S("@W_HDW220","@W_HDW500","02d")

@W_HDW0=AsString(@W_HDW300)+AsString(@W_HDW400)+AsString(@W_HDW500)

Input:@W_HDW200=12,@W_HDW210=34,@W_HDW220=56

Result:@W_HDW300=12,@W_HDW400=34,@W_HDW500=56,@W_HDW0=123456

(Ensure the data always is two bits; otherwise occur error. reference the other chapter of W2S function)


ATan??

Function

var = ATan(A1)

Description

Return a arctangent value,the radian ranges -pi/2 to pi/2.

Parameters

A1:Can be float, address or variable.

Val:radian of return value.

Example

@W_HDW20= Atan (@W_HDW10) 'save the arctangent value of (HDW10) to (HDW20)

Input: @W_HDW10=1.000,@W_HDW20=0.785

Notice: please call RadToDeg function convert radian to angle.


ATan2??

Function

val = ATan2(A1,A2)

Description

Return the arctangent value of A1/A2,radian range

Parameters

A1, A2: Address or variable.

Val: return value is a radian, range -pi to pi.

Notice: ATan2 use sign of two parameters to define the quadrant of return value.

Example

@W_HDW20= ATan2 (@W_HDW10,@W_HDW12) 'save the arctangent value of (HDW10/HDW12) to (HDW20).

Input:@W_HDW10=1.0,@W_HDW12=1.0,

Result: @W_HDW20=0.785

Notice: please call RadToDeg function convert radian to angle.


B2W???

Function

B2W(A1, A2,length)

Description

Convert a array (begins with A2, unit: byte, to another array ( begins with A1,unit:word).

Parameters

A1:Saving address after converting

Notice:must be address(e.g.:@W_HDW000002)

A2:Address of the value be converted

Notice:must be address(e.g.:@W_HDW000002)

Length:The length of conversion

Notice:It can be address or variable.

Return value:None

Notice:This is a subprogram, it has no return value.

Example

B2W(@W_HDW100,@W_HDW10,2) 'convert (@W_HDW10) to the length of 2,save as the result that begins with @W_HDW100.

Input: @W_HDW10=1A2B

Result: @W_HDW100=2B

@W_HDW101=1A


BCD??

Function

val = BCD(A1)

Description

Convert A1(binary) to BCD, save the result as return value.

Parameters

A1:The binary be converted, it can be a address or variable.

Val:Return value, BCD code; it can be a address or variable.

Notice:Return value is a word; it hexadecimal corresponds to BCD code.

Example

@W_HDW20=BCD(@W_HDW10) 'convert HDW10 (binary) to BCD code, then save in (HDW20)

Input: @W_HDW10=11111111(binary),

Result: @W_HDW20=255


Beep

Function

Beep

Description

Buzzers send out beep.

Parameters

None

Example

if @B_HDX100.0=1 then 'beep when the bit switch HDX100.0 set ON

beep

endif

result: HMI beep when bit switch HDX100.0 set ON.


BIN??

Function

Val = BIN(A1)

Description

Convert A1 (BCD) into binary, save the result in return value.

Parameters

A1: The BCD code is converted; it can be address or variable.

Val: Return binary value,it can be address or variable.

Example

@W_HDW20=BIN(@W_HDW10) 'convert HDW10(BCD) to binary, save the result in (HDW20)

Input: @W_HDW10=255

Result: @W_HDW20=11111111 (binary)


BMOV???

BMOV sub function

Function

BMOV(A1, A2,length)

Description

Copy data with a designated length from source address A2 to A1.

Parameter

destAddr: saving address

srcAddr: source address

length: data length

Example

@W_HDW20 = 20 'assign value to HDW20

@W_HDW21 = 21 'assign value to HDW21

@W_HDW22 = 22 'assign value to HDW22

BMOV(@W_HDW10,@W_HDW20,3) 'assign the word address of HDW20, HDW21, HDW22 to HDW10, HDW11, HDW12

Result:

@W_HDW10 = 20

@W_HDW11 = 21

@W_HDW12 = 22


Chr??

Function

val = Chr(A1, A2, ...)

Description

Convert integer parameter into correspond ASCII character,return the character string.

Parameters

A1, A2....: converted integer; it can be a address or variable.

Val:return value, can be a address or variable.

Example

@W_HDW100=Chr(@W_HDW20,@W_HDW21,@W_HDW22,@W_HDW23,@W_HDW24)

'convert the value of(HDW20,HDW21,HDW22,HDW23,HDW24) to ASCII character,assign the value to (HDW100)

Input 72,69,76,76,79 step by step according to HDW20,HDW21,HDW22,HDW23,HDW24,result returns HELLO to (@W_HDW100).


ClrB???

ClrB subfunction

Function

ClrB(A1)

Description

Set the bit of A1 as FALSE(0).

Parameters

A1:System address(bit)

Notice; subprogram has no return value.

Example

ClrB(@B_HDX100.0) 'assign 0 to(@B_HDX100.0)


????

Constant

Description

Script supportd stable constant, users can use on script:

pi = 3.14159265358979321

TRUE = 1

FALSE = 0

Example

Dim a as integer 'define integer a

a = RadToDeg(pi) 'convert radian pi to angle then assign to a,RadToDeg function is used to convert radian to angle.

@W_HDW11 = a 'assign a to (HDW11)

Result: @W_HDW11=180


Cos??

Function

Val = Cos(A1)

Description

Return a cosine value of an angle.

Parameters

A1:a float radian of angle, it can be an address or variable.

Val:return float value, it can be a address or variable.

Example

Dim a, b as floating 'define float a, b

b = pi/3 'convert the value of HDW11 to float and assign to 'b'.

a=Cos(b) 'return the cosine value of'b' and assign the result to 'a'.

'to add the following sentence if need to view the return value:

Float2D("@W_HDW20",a) 'the float value of a written into HDW13.

Result:@W_HDW20=0.5

Notice: please call RadToDeg function convert radian to angle.


9.14.22 D2F???

D2F subfunction

Function

D2F (A1, A2) or A1= D2F (A1, A2)

Description

Convert the 32 bit integer format data to float then output the result.

Parameters

A1: required data, begin with"@";

A2: source data, begin with"@";

Example

D2F(@W_HDW2,@W_HDW0) 'convert the double word (HDW0) to float, save the result to (HDW2).

@W_HDW2=D2F(@W_HDW2,@W_HDW0) 'convert the double word (HDW0) to float, save the result to (HDW2).

Result: HDW0=100, HDW2=100


D2Float

Function

F= D2Float("A1",F)

Description

Convert the designated value to floating then assign to variable.

Parameters

A1: Must begin with address"@";

F: Define the floating by self;

Example

dim F as floating 'define F as floating

F=D2Float("@W_HDW10",F) 'assign the value of (HDW10) to F in floating

Float2D("@W_HDW12",F) 'copy the floating value of F to HDW12 register,use to display result.

Result:HDW10=200,

HDW12=200.


DegToRad function

DegToRad

Function

A2 = DegToRad(A1)

Description

Convert the angle into correspond radian, and display.

Parameters

A1: inputting angle supports address, other variable or floating.

A2: outputting radian supports address, other variable or floating.

Example

@W_HDW12=DegToRad(@W_HDW10) ' input angle on (HDW10),convert to correspond redian and copy to (HDW12)

Result: HDW10=180; HDW12=3.14159

dim a as floating ' set variable

dim b as floating ' set variable

b=30 ' input angle

a=DegToRad(b) ' convert the length of radian and copy to variable {a}

float2d("@W_HDW0", a) ' display the value of floating on(HDW0)

Result: HDW0=0.52360


DIM ... AS ...

Function

Dim "variable" as "date type"

Description

Declare a variable, stable the type of data.

Parameters

Variable: begin with letter, other character can be letter, numbers, underscores ('_'),must begin with '@' if it is address;

Data type:string,floating,integer;

Notice: use the variable of Dim during running, cannot change the type, Dim will be missed if not define the type of variable. Variable can be declared once.

Example

dim a as integer 'define a as integer

dim @W_HDW0 as floating 'define @W_HDW0 as floating

dim hi as string 'define "hi" as string

Result:

a is integer

@W_HDW0 is floating

hi is string


Do

DO ... LOOP

Function

Do [While | Until condition]

[statements]

Loop

or

Do

[statements]

Loop [While | Until condition]

Description

Condition determent instruction.

Do while.loop executes an instruction of block repeatedly when condition is true.

Do until.loop executes an instruction of block repeatedly until condition is true.

Parameters

Condition: determine condition; obtain the expression of True or False.

Statements: execute one or more instructions repeatedly when condition is True or until condition is True.

If condition is true, all statements are executed until the Wend statement is encountered. Control then returns to the While statement and condition is again checked. If condition is still True, the process is repeated. If it is not true, execution resumes with the statement following the Wend statement.

Example

dim i as integer 'end DO loop when i=100

do while i<100

i=i+1

@W_HDW0=i

loop

Result: HDW0=100


End

Function

Terminates the script immediately.

Description

End the execution of script.

Parameters

Statement: Judging condition, use with IF together. end script when meet condition.

Example

If a = 10 Then End 'end script when a=10.

Result: End the script program.


Exp

Function

A1=Exp(A2)

Description

Returns the power value of e (natural logarithm), save the outputting result to A1, e=2.71828182846.

Parameters

A1: the goal date: the power floating value of returning, must begin with '@'(e.g.@W_HDW10);

A2: Source data, natural exponential function, must be integer or variable. Cannot not begin with the address of "@"(e.g.@W_HDW10)

Example

dim a as integer 'define a as integer

a = @W_HDW2 ' assign the value of (HDW2) to variable a

@W_HDW0= Exp(a) 'exponential is the value of (HDW2),save result to(HDW0)

Result: HDW2=2,

HDW0=7.38905600


F2 D subprogram

F2D

Function

F2D (A1, A2)

Description

Convert a 32 bit floating to integer format, then output the result.

Parameters

A1:Goal date, the value can be a address(e.g.@W_HDW12).

A2:source date, it can be a address or other variable.

Example

F2D(@W_HDW12,@W_HDW10) 'convert the floating of (HDW10) to integer, save in (HDW12).

result:

HDW10=200,

HDW12=200


F2S???

Function

F2S (A1,A2,s1)

Description

Output a format of floating that in the type of string.

Parameters

A1: source address, used to store floating, the value is a address(e.g.@W_HDW200);

A2: Goal address, used to store string after converted, value is a address(e.g.@W_HDW100).

S1: the format of displaying goal data. such as the format of 03.03f,f, used for outputting a single-precision in the form of decimal.m.nf:means m column and n decimals when outputting.

Example

F2S("@W_HDW200", "@W_HDW100", "03.03f") '(HDW200) is floating input,(HDW100) is text output;

result:HDW200=1.22365,

HDW100=1.224


FILL subprogram

FILL

Function

FILL (A1, A2, A3)

Description

Write the same value to designated address constantly.

Parameters

A1: The beginning address, it can be a address(e.g.@ W_ HDW25);

A2: Source data, it needs to be written in continuous value, the value can be a address, variable or constant;

A3: The number of operation, writing address number, it can be a address, variable or constant;

Example

FILL (@W_HDW25, 10, 3) 'At the beginning three address of @W_ HDW25 is 10.

result:At the beginning three address of @W_ HDW25 is 10,@W_ HDW25=10,@W_ HDW26=10,@W_ HDW27=10.


Float2D function

Float2D

Function

Float2D (A1,A2);

Description

Copy floating value to the address.

Parameters

A1: Goal address, the value must be address (e.g.@W_HDW102);

A2: Source data, it can be floating;

Example

dim f as floating 'define f as floating

f=1.1 'assign a designated value to f

Float2D ("@W_HDW102",f) 'assign the value f to HDW102

Result: HDW102=1.1


For

For. to. step.next

Function

For counter = start to end Step

[Statements]

Next

Description

Execute a command repeatedly for designated times.

Parameters

counter:Work as a variable for loop counter;

start:The start value of counter, it can be any variable type or expression;

end:The end value of counter, it can be any variable type or expression;

step:Every loop, the changed value of counter is step value, step default if it is not designation. step default is -1,when start>end,step default is 1 when start< end. It can be any variable type or expression;

statements:Between For with Next, execute instruction set of designated times;

Set a loop of for...Next in another loop, it can nest call the loop of for...Next. Different from a while, for only search once value from end. Empty for loop will be ignored, and cannot delay time.

Example

'Use HDX2.0 to trigger the loop

for i=100 to 0 step -5 ' set the start is 100,end is 0,subtract 5 every time, execute 20 times totally.

@W_HDW100=@W_HDW100+1 ' execute (HDW100+1) 21 times totally, the final result is 21.

Next

@B_HDX2.0=0

Result: HDW100=101


Function

Function

Function name (arglist)

statements

name = expression

statements

End Function

Description

Differ from internal function, need to declare the name, parameter, code of the function.

Parameters

Name:function name.

arglist:stands for the variable list of parameter, this parameter will be entered when calling function. use comma to separate.

statements:a set of code in running function body.

Notice: it can not define a function program at any other program body. Write name first and then follow with parameter list, when calling function. Declare function must before calling. in the internal function body, it can assign to a function name from return value at any place. Return value is 0 if not assign function name. Functions can recursive call, but, it may lead to stack overflow.

Example

Function sincos (angle as floating)

sincos = sin(angle) + cos(angle)

End Function<

........

@W_0002 = sincos(pi/2)

........


goto ???

Function

Goto label

Description

Go to the designated row unconditionally in a function body.

Parameters

Label: target character, start with letter in row label, end with(:)of any string.row label has no sensitive to the format of letter.

notice:Goto only can jump into the internal function that visible row.

Example

Goto sd 'go to the row which start with "sd";

Result: Go to sd row.


H2A??

Function

A1 = H2A (A2)

Description

Convert a binary(16 bit) to hexadecimals(4 bit) of ASCII.

Parameters

A1:return value, string, it can be an address or variable.

A2:binary is needed to be converted, the value can be a address or variable.

Example

@W_HDW100= H2A (@W_HDW0) ' convert the binary of (HDW0) to character and save in (HDW100).

Result: HDW0=200,

HDW=100


Hypot??

Function

Var = Hypot (expr1, expr2)

Description

Calculate the value of the hypotenuse of a right triangle.

Parameters

expr1, expr2:source data, the two sides of right triangle. it must be address;

Var:target data,it must be address;

Notice: hypot function can support integer and floating when the format of source data and target data are the same.

Example

@W_HDW200=Hypot (@W_HDW105,@W_HDW108) ' input the value of right-angle side at (HDW105) and (HDW108),and assign the result of the hypotenuse to (HDW200).

Result: HDW105=3,

HDW108=4,

HDW200=5


If

IF ... THEN ... ELSE ... END IF

Function

If condition Then

Statements

[Else

elsestatements]

End If

Description

Execute correspond instruction when fulfil condition. condition will be tested when executing if. it will execute the later instruction block of then, if condition is true. otherwise, execute the later of else. complete the two instructions, next execute the later of End if.

Parameters

condition:any expression, the value can be true or false.

statement:execute the instruction block when condition is true.

else statement:execute the instruction block when condition is false.

Example

if @W_HDW105=200 then ' judging condition: whether the value of (HDW105) is 200

@W_HDW108=1 'the value of (HDW108) is 1 if fulfil condition

else

@W_HDW200=1 ' the value of (HDW200) is 1 if not fulfil condition.

Endif

Result:

HDW105=199;

HDW108=0;

HDW200=1


InStr

Function

var = InStr ("str1", "str2")

Description

Return the position of str1 in str2(start with 0), set -1 if not find.

Parameters

str1: source string, it can only be string, not address;

str2: target string, it can only be string, not address;

var: return value, the format of data must be string;

Example

dim a as floating

a = InStr ("Hello", "o") ' calculate the position of"o"in"hello".

float2d ("@W_HDW0",a) ' return value is 4.(start with 0)

Result: HDW0=4


9

InvB subfunction

Function

InvB (A1)

Description

The state of inverse bit, it is a subfunction, so has no return value. Achieve the state of switching address constantly.

Parameters

A1: it is an address.

Example

InvB (@B_HDX0.1) 'switch the state if (HDX0.1).

Result: Switch the state of (HDX0.1) constantly.


IsFloating

Function

A2=IsFloating (A1)

Description

Decide whether a parameter is floating, return true if it is floating, otherwise return FALSE.

A1: source data, variable;

A2: target data, must be variable, it cannot use system address directly.

Example

dim a as integer

dim b as floating

b= D2float ("@W_HDW200",b) 'assign the value of (HDW200) to b

a = IsFloating (b) 'judge whether b is floating or not

@W_HDW300=a 'save the result to (HDW300)

Result: HDW300=1


9

IsInteger

Function

A2= IsInteger (A1)

Description

Determine whether a parameter(A1) is integer, returen TRUE if the parameter is integer, otherwise return FALSE.

Parameter

A1: Source date, it is variable or number;

A2: Target date, must be variable, it cannot use system address directly;

Example

dim a as integer

a = IsInteger (20) 'determine whether 20 is integer

@W_HDW300=a ' display the result on (HDW300)

Result: HDW300=1


IsString function

IsString

Function

val = IsString(expr)

Description

Determine whether a parameter is string, return TRUE if it is string, otherwise return FALSE.

Parameters

Expr: source string, it can be a variable or string, not address;

Val: target date, the result must be variable, cannot be a address;

Example

dim a as integer 'define variable, display the result;

a= isstring ("hello") 'determine whether"hello"is string;

@W_HDW0=a 'assign the result to (HDW0)

Result: HDW=1


LCase??

Function

A2 = LCase(A1)

Description

Return converted string all parameters to low edian.

Parameters

A1: source string, it can be a address or variable;

A2: outputting string, it can be a address or variable;

Example

@W_HDW33 = LCase (@W_HDW25) 'input source sting on (HDW25),convert it to target string and display the result on (HDW33);

Result: HDW25=HELLO

HDW33=hello


Left??

Function

Val =Left (String, Length)

Description

Count a string from left then return string length.

Parameters

String: source string; it can be an address or string.

Length: return the number of character. It can be an address, integer or variable. Return empty string if length<1.return the whole string if length not less than the character number of string.

Val:target string, outputting string, it can be a address or variable.

Example

@W_HDW30=Left (@W_HDW36, @W_HDW40) '(HDW36) used to input source string,(HDW30) used to display the string result;

Result: HDW36=hello,

HDW40=2,

HDW30=he


Len

Function

Length=Len(String)

Description

Return the string length.

Parameters

String: source string, it can be a address or string;

Length: target data, return value, it can be a address, variable, integer or floating;

Example

@W_HDW30=Len (@W_HDW36) 'count the character number of (HDW36),save the result to (HDW30);

Result: HDW36=hello

HDW30=5


Log??

Function

a= Logn (x)=Log(x)/Log(n)

Description

Log function:return the natural logarithm of the value.

Parameters

a: source date,it can be a variable, but it cannot use address directly;

x, n: source date, it can be a variable, but it cannot use address directly;

Example

Dim a as integer 'define a as integer;

Dim b as integer 'define b as integer;

Dim c as integer 'define c as integer;

b=@W_HDW10 'assigns a value to b

c=@W_HDW20 'assigns a value to c

a=Log (b)/Log(c) 'count logarithm

@W_HDW0

=a 'assign the result to (HDW0)

Result: HDW10=27,

HDW20=3,

HDW0=3


Log10??

Function

a=Log10(x)= Log(x)/Log(10)

Description

Log function: return the natural logarithm.

Parameters

A: target data, result can be variable, cannot use address directly;

x: source data, it can be variable that must be the multiples of 10,cannot use address directly;

Example

dim a as integer 'define a as integer

dim b as integer 'define b as integer

b=

@W_HDW10 'assign a value to b

a= Log (b)/Log(10) 'result

@W_HDW0=a 'assign the result to (HDW0)

Result: HDW10=100,

HDW0=2


LTrim function

LTrim

Function

val=LTrim("string")

Description

Remove the left empty part of the string and return.

Parameters

Val: target sring, it can be either a variable or address;

string: source string, it can be either a variable or address;

Example

dim a as string

a=Ltrim(" hello")

@W_HDW103=a

Result: HDW103=hello


MAX??

Function

A1=MAX(A2,A3)

Description

Compare the value of A2 and A3, assign the greater number to A1.

Parameters

A1: return value (used to store the greater number between A2 with A3).

A2: the first comparison value.

A3: the second comparison value.

Notice: A1,A2,A3 only used in unsigned integer or unsigned address.

Example

DIM A1 as integer

@W_HDW106=10 'assign the value to (@W_HDW106),unsigned decimal word.

@W_HDW107=5 'assign the value to (?@W_HDW107),unsigned decimal word.

A1 = Max(@W_HDW106,@W_HDW107)

@W_HDW105 = A1

Result: @W_HDW105 = 10


Mid

Function

A1=mid(A2,start,length)

Description

Returns a string contain a specified characters length from a string.

Parameters

A1: string contains selected characters

notice: A1 must be a string

A2: string of being selected

notice: A2 must be a variable or address

Start: the start position of string

notice: Start must be a variable or address, it means that count begin with 0.

Length: the designated length of string

notice: length no more than 127

Example

DIM A1 as string

A1 = Mid("hellokitty",1,2) 'select the string of in "

@W_HDW106=A1

Result: @W_HDW106 'display "el" on text input and output window


MIN??

Function

A1=MIN(A2,A3)

Description

Compare the value of A2 and A3, assign the smaller number to A1.

Parameters

A1:return value (used to store the less number between A2 with A3).

A2:the first comparison value.

A3:the second comparison value.

Notice: A1,A2,A3 only used in unsigned integer or unsigned address.

Example

DIM A1 as integer

@W_HDW106=10 'assign the value to (@W_HDW106),unsigned decimal word.

@W_HDW107=5 'assign the value to (?@W_HDW107),unsigned decimal word.

A1 = Min(@W_HDW106,@W_HDW107)

@W_HDW105 = A1

Result: @W_HDW105 = 5


MSeconds

Function

A1=MSeconds( )

Description

A1 is used to display the current microseconds of system.

Parameters

A1:used to store the current microseconds of system.

Notice: A1 is unsigned integer variable or unsigned integer address.

Example

DIM A1 as integer

@W_HDW0= 10 'assign a value to (@W_HDW0), unsigned decimal word

A1=MSeconds() 'return the current microseconds of system to A1

@W_HDW0= A1 'display microseconds on screen,(HDW0) is a unsigned decimal integer address

Result: @W_HDW0 will generate the time value of changing microseconds unit.


NewNoAddr

Function

A1= NewNoAddr (A2, length)

Description

At the basic of source address A2,offset designated length,obtain a new address A1.

Parameters

A1:address after offsetting

Notice: A1 must be variable.

A2: source address

Notice:A2 must be address(e.g.:"@W_HDW000002")

Length:offset length

Example

DIM A1 as string

A1=NewNoAddr("@W_HDW0",50) '(HDW0) offsets 50 words address(16 bit),and save the result to A1

@W_HDW1=A1 '(HDW50) save in A1

Result: (@W_HDW1) character input/display will show @W_HDW50


NewStatAddr

function

A1= NewStatAddr(A2,length)

description

At the basic of source address A2,offset the designated length,to obtain a new station A1.

parameters

A1: The address after offsetting

Notice: A1 must be variable.

A2: Source station address

notice:A2 must be address (e.g.:"@W_1:10").

Length: offset length

Example

DIM A1 as string

A1=NewStatAddr("@W_1:10",2) 'address 10 of station address1 that offset 2 station addresses,then save the result to A1

@W_HDW1=A1 'address 3:10 is saved in A1

Result: @W_HDW1 character input/display will show @W_3:10


NStringCompare

Function

A1= NStringCompare(A2,A3,length)

Description

Compare whether the designated length of two strings is the same,return 1 to A1 if yes,otherwise return 0.

Parameters

A1:return value (compare the designated length of two strings,display 1 when equal,else 0).

Notice: A1 can be a address integer or variable.

A2:the address of string to be compared

Notice: A2 must be address.

A3:source string

Notice: A3 must be variable or constant string.

Length:string length to be compared

Example

@W_HDW1= NStringCompare("@W_HDW0","87654",5)

if @W_HDW1=1 then

@B_HDX10.0=1 'result: HDX10.0 set ON 'when the two strings are the same.

endif

if @W_HDW1=0 then

@B_HDX10.0=0 'result:HDX10.0 set OFF 'when not equal.

endif


power??

Function

var = power(expr1, expr2)

Description

The value of [expr2] to the power of [expr1] will be assigned to Var.

Parameters

var: return value.

expr 1: base number.

expr 2: power number.

Example

Dim a as floating

a=power (2, 3) 'the value of 3 to the power of 2 is assigned to a.

Float2D("@W_HDW10",a) 'assign the float value of a to @W_HDW10

Result: @W_HDW10=8


RadToDeg??

Function

Var= RadToDeg(expr)

Description

Convert radiant value to degree, then assign to Var.

Parameters

Var: return degree value.

expr: input radiant value.

Example

Dim a as floating

a = RadToDeg(pi) 'assignt the degree value of ? to a.

Float2D("@W_HDW4",a) 'assign the degree value to address "@W_HDW4".

Result: @W_HDW4=180


RAND??

Function

Var = rand(expr1)

Description

Generate a random number.

Parameter

Var: generated random number.

Expr1: the base number.

Example

@W_HDW0=rand(@W_HDW0) 'Set the value of address@W_HDW0 as the base number to generate random number.

Result: @W_HDW0 random number.


ReadAddr???

Function

Word = ReadAddr(A1)

Description

Assign the red value from A1 to word.

Parameter

Word: return value

Example

Dim word as integer

@W_HDW100=10

word = ReadAddr("@W_HDW100") 'Read the value of address @W_HDW100 and assign to word.

@W_HDW200=word

Result:@W_HDW200=10


Right??

Function

val = Right(string, length)

Description

Return the designated number of string to val.

Parameter

String: the operated string.

Length: the designated number of byte required to return, count from the right side.

Example

@W_HDW103= Right("Hello", 3) 'return "llo"

Result:@W_HDW103="llo"


RTrim??

Function

val = RTrim(str)

Description

Clear the empty part on the right side of string [str], then assign the empty part to val.

Parameter

val: return value.

str: the string need to be operated.

Example

@W_HDW0 = RTrim(" -Hell o- ") ' retrun" -Hell o- "

Result: @W_HDW0 'display " -Hell o-"


SetB

SetB sub

Function

SetB(A1)

Description

Set the bit A1 ON.

Parameters

A1:Bit address

Example

SetB(@B_HDX100.0) 'Set the address {@B_HDX100.0} ON

Result: @B_HDX100.0=1


SignedInt16

Function

val = SignedInt16(A1)

Description

Assign the value to {val} from address A1 which is signed integer.

Parameters

A1:contain signed integer as "@W_HDW000002"

Val:return value

Example

Dim a as integer 'Integer variable a

a = SignedInt16("@W_HDW0") 'read signed integer from HDW0 addresses and assign the value toa

@W_HDW2=a 'assign the value a to HDW2

Input: @W_HDW0=-2:

Result: @W_HDW2=-2.


SignedInt32

Function

val = SignedInt32 (A1)

Description

Assign the value to {val} from address A1 which is signed even integer.

Parameters

A1: the address contains signed even integer

Val: Return value

Example

Dim a as integer 'define {a} as a integer

a = SignedInt32("@W_HDW0") 'read signed even integer from HDW0, then assign this value to a.

@W_HDW2=a 'assign the value of a to HDW2

@W_HDW13=a>>16

Input: @W_HDW0=-2

Result: @W_HDW2=-2

@W_HDW13=-1


Sin??

Function

val = Sin(A1)

Description

Implement sin calculation to computing the value in A1 then assign to val.

Parameters

A1: A1 needs to be a angle.

Val: Return value.

Example

Dim a as floating 'floating variable a,b

a=sin(pi/6) 'return sinb to a

Float2D("@W_HDW13",a) 'assign the value of the floating variable a to address HDW13.

Result: @W_HDW13=0.5


SleepA

Function

SleepA(T)

Description

Wait time T(ms).

Parameters

T: wait time, the unit is [ms]

Return value: not available.

Example

SleepA(10) 'wait 10ms

Result: When the script runs to SleepA(10) then wait 10ms to continue running.


Sqr

Function

val = Sqr(A1)

Description

Assign a square root value of A1 to val.

Parameters

A1:the data need to be operated

Val:Return value

Example

@W_HDW0 = Sqr(4) 'calculate the square root of HDW0

Result: @W_HDW0=2


Sub

Function

Sub name (arglist)

statements

End Sub

Description

Declare the name, parameters and codes of the Sub (sub function)

Parameters

Name:naming rules refer to variable.

Arglist:variable list.

Statements: the code set of the sub function.

Example

sub samesub(a,b as integer) ' samesub and integer variable a,b

c=a+b

@W_HDW0=c

endsub

samesub(1,12) 'call function samesub

Result: @W_HDW0=13


SWAP

SWAP subfunction

Function

SWAP(A1,length)

Description

Swap the High endian with the low endian from address A1, swap length is adjustable.

Parameters

A1:the swapped high edian, must be a address as HDW_000002.

Length:swap length.

Return value:Not available.

Example

@W_HDW103=0x1234 'assign value to HDW103

@W_HDW104=0x2345 'assign value to HDW104

@W_HDW105=0x2565 'assign value to HDW105

@W_HDW106=0x2675 'assign value to HDW106

SWAP(@W_HDW103,4) 'swap the high and low endian for the 4 adjacent addresses start with HDW103.

Result:

@W_HDW103=0x3412

@W_HDW104=0x4523

@W_HDW105=0x6525

@W_HDW106=0x7526


Tan

Function

val = Tan(A1)

Description

Implement tan calculation to computing the value in A1 then assign to val.

Parameters

A1:A1 needs to be an angle.

Val:return value.

Example

Dim a as floating 'define a floating variable a

a=TAN(pi/3) 'calculate the tangent value of pi/3 and assign to a

Float2D("@W_HDW16",a) 'assign the value of a to HDW16

Result: @W_HDW13=1.732


Trim

Function

val = Trim(A1)

Description

Return a value of a address without empty string next to it.

Parameters

A1:The operated string

val:return value

Example

@W_HDW1=Trim(" ab ")

Result: @W_HDW1="ab"


UCase

Function

val = UCase(A1)

Description

Capitalize the string data, and then assign the value to val.

Parameters

A1:operated string, address or variable.

Val:Return value

Example

@W_HDW1=ucase("abcd") 'Capitalize abcd then assign the value to HDW1

Result: @W_HDW1="ABCD"


W2B

Function

W2B(A1, A2, A3)

Description

Replace the high endian of [A2]+1 with the high endian of A2.

Parameters

A1: operated address.

A2: source address.

A3: the conversion length.

Return value: not available.

Example

@W_HDW0 = 4660 'assign 16bit value 1234 to HDW0.

@W_HDW1=0x5678 ''assign 16bit value 5678 to HDW1.

@W_HDW2 = 0x2425 ''assign 16bit value 2425 to HDW1.

@W_HDW3 = 0x3536 ''assign 16bit value 3536 to HDW0.

@W_HDW4 = 0x1415 ''assign 16bit value 1415 to HDW0.

W2B(@W_HDW20,@W_HDW0, @W_HDW10)

@W_HDW10=1: save the high endian {34} of HDW0 to HDW20.

Result: @W_HDW20=0x34, @W_HDW21=0, @W_HDW22=0


W2D

Function

W2D(A1, A2)

Description

Convert the unsigned Word to unsigned Dword and save the result in A1.

Parameters

A1: operated address.

A2: source address.

Return value.

Example

unsigned decimal word

@W_HDW0 = 1234 'assign 1234 to HDW0.

W2D(@W_HDW2, @W_HDW0) 'convert unsigned word {1234} from HDW0 to Dword and save in HDW2

Result: @W_HDW0=12345,@W_HDW2=12345,@W_HDW3=0

signed decimal word

@W_HDW0 = -12345 'assign value to HDW0: convert {-12344} to unsigned decimal word is {53191}.

W2D(@W_HDW2, @W_HDW0) 'save unsigned Dword to HDW0

Result: @W_HDW0=-12345,@W_HDW2=53191,@W_HDW3=0


W2F

Function

A1 = W2F (A2)

Description

Convert a 16bit integer to a 32bit floating, and then save to the next word of A1.

Parameters

A1: operated address.

A2: source address.

Return value: not available.

Example

1. A1, A2 are addresses

@W_HDW0 = 1234 ' assign unsigned word {1234} HDW0 @W_HDW1=W 2F(@W_HDW0) ' Convert {1234} to a 32bit floating and then save to HDW1, HDW2.

Result: @W_HDW1=1234'32bit floating

2. A1 is an address,A2 is variable

dim a as integer

a=134 'define a integer 134 to a,

@W_HDW2=W2F (a) 'convert to 32bit floating save to HDW1, HDW2.

Result:@W_HDW1=134' 32bit floating


W2S

Function

W2S(A1,A2,S1)

Description

Convert integer word in address A1 text as S1 format, and then save to A2.

Parameters

A1: operated address.

A2: source address.

S1: saving format.

1. d format:Decimal format.

d:real data length.

Md:designated data length.

0md:designated data length if the length is shorter than m add 0 at the left.

2. oformat:Unsigned octonary format. Mo and 0mo is also applied.

3. x format:unsigned Hex integer format?Mx and 0mx is also applied.

4. c format: ASCII format.

Example

1. Decimal format

@W_HDW1=1456 'assign value {1456} to HDW1.

W2S("@W_HDW1", "@W_HDW10", "6d") ' convert{1456} to decimal text and save to HDW10.

Result: @W_HDW10 shown "1456"

2. 0md

@W_HDW1=1456 ' assign value {1456} to HDW1

W2S("@W_HDW1", "@W_HDW10", "06d") ' convert{1456} to integer decimal text and add 2 {0} on the left of the data then save to HDW10.

Result: @W_HDW10 show text "001456"


While

WHILE ... WEND

Function

While condition

[statements]

Wend

Description

If the condition is true, then all the commands before Wend in the statement will be executed then recheck the condition, if the condition is false, the command after Wend will be executed.

Parameters

Condition:Number or string, the result represent as True or False.

Return value: not available.

Example

while @W_HDW1>50 'the condition is the value of HDW1 bigger than 50.

@W_HDW1=@W_HDW1-1 'when the condition is true, execute subtract 1 from 1HDW.

wend

@W_HDW2=@W_HDW2+1 ' when the condition is false, execute add 1 from 1HDW.

Execute: If HDW1=60,after executed; HDW1=50, if the condition is true.


WriteAddr

Function

WriteAddr(A1,A2)

Description

Assign the value from A2 to address A1.

Parameters

A1: operated address

A2: source address

Return value: not available.

Example

dim f as integer ' integer f

f=13 ' assign the value 13 to f

WriteAddr("@W_HDW1",f) ' write the value to HDW1.

WriteAddr("@W_HDW10",@W_HDW2) ' write the value from HDW2 to HDW10.

Result:

HDW1=13

HDW10= HDW2'IF HDW2=1456,Then HDW10=1456;IF HDW2=-123,Then HDW10=-123


Script Type

Script divided into three categories:

1. Background script: Run independently when start project, screen updates have no influence and valid of all scripts.

2. Global script: It began to run when project start, screen update, switch will affect all of script during running.

3. Screen script: Only run under the designated screen. Screen script start running until screen is closed or switched.

Notice: background: interval unit of running time is 1 millisecond.

Edit background script: double click [background script] on project manager. Then click ??: ??: 1.png to add it, set the timing interval to enter screen script. Shown as following:

Global script can be divided into four categories:

Property | Description
Initialize | The script will be executed once during loading project.
Close | The script will be run once during closing HMI project.
Timing | Trigger to run once in a while until project end, during running. Each project can be set global script of more than one timing trigger.
Bit trigger | Script will be repeat executed when meet the condition of bit trigger.

Bit trigger has four conditions

Property | Description
TRUE | Detect the value of toggle bit constantly, script will always execute when the value is TRUE.
FALSE | Detect the value of toggle bit constantly, script will always execute when the value is FALSE.
Rising | Detect the value of toggle bit constantly; script will be once executed when the value changes FALSE from TRUE.
Falling | Detect the value of toggle bit constantly, script will be once executed when the value changes TRUE from FALSE.

Notice: global script of bit trigger can also have more than one in one project.

In order to edit global script, double click [global script] from project manager.

Screen script can be divided into four categories under running condition:

Property | Description
Initialize | Run under loading screen, the script will be executed once during running.
Close | Run under closing screen, the script will be executed once during running.
Timing | Trigger to run at every once until screen is closed, during running.
Bit trigger | Script will be repeat executed when meet the condition of bit trigger, under running project.

Bit trigger divided into four conditions.

Property | Description
TRUE | Detect the value of toggle bit constantly, script will always execute when the value is TRUE.
FALSE | Detect the value of toggle bit constantly, script will always execute when the value is FALSE.
Rising | Detect the value of toggle bit constantly; script will be once executed when the value changes FALSE from TRUE.
Falling | Detect the value of toggle bit constantly, script will be once executed when the value changes TRUE from FALSE.

Right click [current screen]-[screen script] to edit screen script.

Global script and screen script have the same categories from above description. The difference between screen script and global script is that screen script runs only during screen operation, and the global script runs only during project operation.


Initialization Script

Summary

Initialization divided into screen initialization script and global initialization script. screen initialization script run once when enter screen at the moment; global initialization script is the moment of loading project, it runs once and is valid of all script.

Setting

Click [global script] from project manager to enter global script editor window.

Double click [initialize] node from "the view of script" on screen script or global script, then edit script.


Trigger Control

General

Trigger control script is that software will check whether the designated bit meet trigger condition every 20ms.script execute once when condition is met until project closed.

Notice:The maximum number of trigger script for one screen is 32.

1. The script guidance.

2. New trigger control script.

Click [global script] from project manager to enter global script editor window.

Double click [initialize] node from "the view of script" on screen script or global script, then edit script.

Condition | Description
TRUE | check monitor bit Every 20ms,script execute once when the bit value is TRUE;
FALSE | check monitor bit Every 20ms,script execute once when the bit value is FALSE;
Bit changed | Execute once when bit switch state.
rising | check monitor bit Every 20ms, script execute once when the bit value from FALSE to TRUE;
falling | check monitor bit Every 20ms, script execute once when the bit value from TURE to FALSE;

Delete trigger control script

Select a trigger control script from script view, and then click [image] from tool bar, the script will be not restored after deleting.

Edit trigger control script property

Edit timing script property is to modify trigger condition and monitor bit, select script from script view then click [image] from tool bar, click [OK] to save after modifying.


Close Script

General

Close script divide into screen close and global close. Screen close is that script will run a period when screen closed. Global close is that script run a period when project closed.

Click [global script] on project manager to open global script editor window.

Double click [close] from " script tree view", open script editor window to edit.


Timing Script

General

The script will run for a designated time interval.

Notice: each trigger script screen of timing and global timing script limit to 32.

New timing script

Click the symbol [image] from script editor bar, shown as figure1.

Property | Description
Cycle | Script runs at designated time interval, unit is 500ms. Background timing script at 1ms per cycle.
Ok | Script created.
Cancle | Cancel the current script setting.

List timing node on script view after creating timing.

Edit timing script property

Edit timing property is to modify cycle, select timing from script view then click [image] from tool bar, and click [OK] to save after modifying cycle, shown as figure 3.


Global Function

General

Global function is a form of code for using,it can be called in any script.the method reference system function.

New global function

Double click [global function] in project manager.

Edit global function parameter

Click [image] from script tool bar, it is used for adding a global function, shown as figure 2.

Property | Description
Function name | Function name cannot be the same as existing.
Return type | None, string, integer, float.
Paremeter1 | The name of paremeter 1.

Notice: function contains no more than are four parameters and cannot be repeated.

Edit global function properties

[Edit] is to modify name and parameter. Click [image] on tool bar.

Call global function

Refer to the call of system function.